Closed Bug 1615767 Opened 9 months ago Closed 9 months ago

Flexible space becomes invisible if used in bookmarks toolbar with many/overflowing bookmarks

Categories

(Firefox :: Toolbars and Customization, defect)

74 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- fixed
firefox75 --- verified

People

(Reporter: danielboontje, Assigned: Gijs)

References

(Regressed 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

74.0b3, adding one flexible spacebar to the left of my bookmark toolbar doesn't work, it's there, but when closing customization menu, the bookmark toolbar is still stuck all the way to the left.

Actual results:

when closing customization menu, the bookmark toolbar is still stuck all the way to the left.

Expected results:

Should behave just like Firefox 73 behaved/behaves.

Component: Untriaged → Toolbars and Customization

Ok, I'm switching over to 73 as my default browser then (was using 74 for lots of months), until this is fixed. :/

I can't reproduce; I see no difference between behaviour on 72, 73, 74 and 75 - the spacer adds several cm of horizontal empty space on the left-hand side of the toolbar.

Can you find a regression window with mozregression ( https://mozilla.github.io/mozregression/ ), and take screenshots before/after to indicate what you're seeing (presumably different from my machine)? Can you reproduce on a clean profile?

Flags: needinfo?(danielboontje)

Ok very interesting, NOT occuring with new profile! (on current FF Beta)
What do you suggest as next step to "fix" my profile?

Flags: needinfo?(danielboontje) → needinfo?(gijskruitbosch+bugs)

(In reply to Dan from comment #3)

Ok very interesting, NOT occuring with new profile! (on current FF Beta)
What do you suggest as next step to "fix" my profile?

Attach your about:support data to the bug and I'll see if anything obvious shows up: https://bugzilla.mozilla.org/attachment.cgi?bugid=1615767&action=enter

Then try copying prefs.js from your "broken" profile to the clean/new profile, see if that "breaks" the new/clean profile.

Otherwise, do you use userChrome.css tweaks of some sort?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(danielboontje)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

We don't have enough information either way right now.

Keywords: regression
Flags: needinfo?(danielboontje)
Attached file file

I don't see anything obvious in the about:support data. Did copying prefs.js from your old profile to a clean one break the flexible spaces there, too?

If so, what's the value of the browser.uiCustomization.state pref? (It's not in the about:support data)

Flags: needinfo?(danielboontje)

No, copying prefs.js didn't break it.

Flags: needinfo?(danielboontje)

Then I don't know what causes this in the profile where this is broken. Are there a lot of bookmarks in your bookmarks toolbar? Any other widgets in the bookmarks toolbar?

Flags: needinfo?(danielboontje)

oh yes, I have looooots of bookmarks in my bookmark toolbar, and a lot of folders. What do you mean by "widgets" ?

Flags: needinfo?(danielboontje) → needinfo?(gijskruitbosch+bugs)

(In reply to Dan from comment #11)

oh yes, I have looooots of bookmarks in my bookmark toolbar, and a lot of folders.

If you copy all the files labeled places from the broken profile to the new profile, does that break things in the new profile?

What do you mean by "widgets" ?

toolbar buttons or the search box or any of the other items you can move around in customize mode, besides the bookmarks toolbar items themselves.

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(danielboontje)

I can also reproduce this, if the bookmark toolbar is overflowed with bookmarks (and the chevron icon is visible at the end).
I have only bookmarks and folder there without any other toolbar items.

So STR from clean profile:

  1. open nightly
  2. make bookmarks toolbar visible
  3. fill the bookmarks container, e.g. by:
    3a. open bookmarks manager, switch to bookmarks toolbar container
    3b. copy the bookmark that's there
    3c. paste a few times
    3d. select all bookmarks in that folder in the bookmarks manager, copy, paste a few times
  4. verify the chevron ( >> ) has appeared in the toolbar
  5. open customize mode
  6. add a flexible space at the start of the bookmarks toolbar, before the "bookmarks toolbar items"
  7. exit customize mode

Expected:
flexible space takes up "some" amount of space.

Actual:
it takes up no space at all.

This was regressed by bug 1601334 because it changed the min-width of toolbarsprings everywhere, including the bookmarks toolbar, and apparently the way XUL layout works is that we end up squashing the spacer to nothing when the toolbar is full. The min-width of 1px was then removed entirely in bug 1608638.

We should probably bring back the original min-width outside of the navbar.

Flags: needinfo?(danielboontje)
Regressed by: 1601334
Summary: "flexible empty space" not working anymore → Flexible space becomes invisible if used in bookmarks toolbar with many/overflowing bookmarks
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bc2743384f7b
re-introduce a min-width for flexible spacers so they work as expected outside the navbar, r=dao
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

I assume we don't need to worry about uplift since the megabar isn't riding 74 to release, but feel free to nominate for approval if that's incorrect.

Fixed on latest Nightly.
Also, I don't think this is related to the urlbar/magebar in any way.

Status: RESOLVED → VERIFIED

Thanks!! (and fixed within 2 weeks even, thx a lot!)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #18)

I assume we don't need to worry about uplift since the megabar isn't riding 74 to release, but feel free to nominate for approval if that's incorrect.

This was a CSS change (to fix a regression from another CSS change) and affects other things than the megabar, and isn't disabled by the pref being off, so yeah, it can do with uplifting.

Comment on attachment 9128839 [details]
Bug 1615767 - re-introduce a min-width for flexible spacers so they work as expected outside the navbar, r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: spacers become useless in the bookmarks toolbar / menubar in some cases
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS only change to revert the effect of part of the regressing bug
  • String changes made/needed: nope
Attachment #9128839 - Flags: approval-mozilla-beta?

Comment on attachment 9128839 [details]
Bug 1615767 - re-introduce a min-width for flexible spacers so they work as expected outside the navbar, r?dao

Low risk css change, uplift approved for 74 beta 9, thanks.

Attachment #9128839 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Regressions: 1654509
You need to log in before you can comment on or make changes to this bug.