Closed Bug 162049 Opened 21 years ago Closed 21 years ago

Tooltips take too long to appear

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: theant, Assigned: asa)

Details

(Keywords: perf)

Tooltips (created by putting a "title=" field inside a link tag) take something
like 3 or 4 seconds to appear.  On Internet Explorer, they only take about 1
second.  This seems much more reasonable.

I'm using Mozilla v1.1b:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

Also, note that I'm using a fast (PIII/576MB) machine, so this isn't a problem
with the system's processing power or anything like that.
WORKSFORME.  Tooltip from a TITLE attribute only takes about 1 second on my
system.  Build 2002080918, Win98.
I thought that kTooltipShowTime is defined as 0.5 seconds ? Even with all the
different processing that's going on (creating the window, etc ...), it
shouldn't take much longer than a second or so.

On my 300MHz Mac (Mac OS 9, build 2002080908), it takes less than 1 second to
popup a tooltip. I'm using the pages on my website (www.bluesweb.org) as a test.
For instance http://www.bluesweb.org/calendar.phtml : evey blue link that you
see, has a popup associated with it. I was even looking ofor a way to slow down
it somewhat, since it's a bit annoying if you slowly move across the page.

Reporter: can you give us a page where it takes so long ? And can you go to
http://www.bluesweb.org/calendar.phtml to try it out ?
Whiteboard: DUPEME
Hmmm... Jo, even on your page, the tooltips take >3 seconds to pop up.  Also on
my page at www.NoDivisions.com under the "Last 5 visitors" section... all the
links there have tooltip popups.

So:
It works for Jo (Mac/build 2002080908), 
 and for Warner (Win98/build 2002080918),
 but not for me (WinXP/build 2002072104).

I'll download the latest nightly build and see what I get.
I installed the latest build, and that didn't fix it.  So I rebooted my machine
(it had been running for ~3 weeks), and that DID fix it.  So... is that a
Mozilla problem, or a WinXP problem?
As long as Mozilla wasn't running for 3 weeks, it must have been Windows XP
(some kind of background cruft that running and stealing cycles).
Reporter: did you check CPU consumption while the problem had been happening?
That usually happens when some stray process consumes a sufficient amount of CPU
time...
Yes I did -- my CPU wasn't being heavily utilized (~5%, or "normal" at idle).

Also... I had previously reported that rebooting fixed the problem.  Well, it
did, temporarily... but a short while later (less than an hour), the problem was
back again.
Anthony, could you check the handle count and GDI object count for the mozilla
process and for other processes on the computer...  something is wrong if the
handle count keeps growing as you use the program.  With a browser and mail
window open, my handle count is ~220 and GDI objects is ~500.  These numbers can
be found in the Task Manager (right-click on the taskbar).
OK, I boot and run only Mozilla.  Mozilla has 130 handles and 116 GDI objects. 
Total handles is 4870 (!) and total GDIs is ~600.  This is after I've closed
everything that's running in the taskbar (AntiVirus stuff, Proxomitron,
OpenOffice quickstart, etc.)

Here are the worst handle hogs... note that they're all Windows processes, not
3rd party apps:

svchost.exe: 1224
explorer.exe: 758
winlogon.exe: 433
csrss.exe: 322
services.exe: 284
System: 266
lsass.exe: 251
svchost.exe 214 (yes there are multiple svchost.exe processes)
==> default owner
Assignee: matti → asa
Keywords: perf
Anthony, is this still a problem in recent Mozilla versions?
Yes.  I'm using build ID 2003020408 and it's still a problem.  It takes 1.5 - 2
seconds for them to appear.

And for some additional weirdness, there are times when they pop up with no
delay.  (That is to say, "normally"... I don't mean "instantly.")  This has
happened maybe 5 times that I can remember, and there is no pattern that I can
see.  As soon as it happens, I think "what did I just do?  Did I close some
certain webpage, exit some other program... WHAT WAS IT??"  But I still have no
idea.
Are you up to date with Microsoft updates?  What video card do you have, and is
the driver recent?  In the Display Settings, Advanced, under Troubleshooting:
how is the driver acceleration set?  Try changing this setting and see what happens.

Have you tried a new Mozilla profile?

Just trying to think of some reasons you'd be having this problem.
Whiteboard: DUPEME
Argh... I wish I could say that one of those things worked.

All the latest MS updates have been installed.

I just uninstalled Mozilla, then deleted the Program Files folder, then deleted
my user profile folder (in the "Documents and Settings" folder), then deleted
anything Mozilla-related in the registry's hkcu\software and hklm\software keys.
 Then I re-installed Mozilla build 2003020408.  Problem still exists.

I just downloaded the latest video driver for my ATi Radeon All-In-Wonder 7500
AGP (which included 3 files: a WDM tv-capture setup, the actual driver setup,
and then an ATi control panel setup).  Rebooted about nineteen times in the
process (I hate Windows).  Problem still exists.

I adjusted the display driver acceleration, down from "full" to just above
halfway.  Problem still exists.

This is a real bugger of a problem, and as with so many Windows-related bugs, I
have a feeling it's going to be a "reinstalling Windows fixed it" bug.  Did I
mention that I hate Windows?
Another strange timing issue I have is that meta refreshes take too long.  For
example, if I make a webpage that has this in the head:

<meta http-equiv="refresh" content="5">

...it doesn't refresh in 5 seconds.  It always takes 10 or more seconds.  Even
when I put the URL in the "content=" setting (which IIRC is the to-spec way of
doing it).

Any thoughts on that, and on whether these two timing issues are related?  In
both cases, things are taking longer than they're supposed to.
That might be it.  Though most people with weird timing problems have Mozilla
going way too _fast_.

See bug 185741, bug 187512, bug 184263
Sick.  Maybe we can get the guys who wrote the "too fast" bug to talk to the
guys who wrote the "too slow" bug and they can engineer a "just right" bug for us.

In any event, I'm glad I'm not the only one... there are apparently some strange
things going on with timing in Mozilla.
Hello everyone,

I just re-installed Windows XP on my machine, and the problem is gone.  Like so
many others, this was one of those bizarre unsolved-mystery Windows bugs. 
Thanks for all your suggestions.  Any further comments before I close this bug?
Closing as WFM per prior comment.

If the problem crops up again, please let us know.
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.