Closed Bug 1621564 Opened 3 months ago Closed 3 months ago

75.0beta source tarballs dont contain third_party/rust/failure/.github-ci.yml -> failure to build

Categories

(Firefox Build System :: General, defect)

75 Branch
defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox73 unaffected, firefox74 unaffected, firefox75 fixed, firefox76 fixed)

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- unaffected
firefox75 --- fixed
firefox76 --- fixed

People

(Reporter: gaston, Assigned: iann_bugzilla)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

same thing for b1 & b2, the source tarball lacks https://hg.mozilla.org/releases/mozilla-beta/file/tip/third_party/rust/failure/.gitlab-ci.yml which is referenced by https://hg.mozilla.org/releases/mozilla-beta/file/tip/third_party/rust/failure/.cargo-checksum.json, thus the build fails. There might be more missing files, dunno yet.. some new process generating tarballs prunes too much files ?

error: failed to calculate checksum of: /usr/obj/ports/firefox-75.0beta2/firefox-75.0/third_party/rust/failure/.gitlab-ci.yml              
                                                                                                                                           
Caused by:                                                                                                                                   No such file or directory (os error 2)                                                                                                   
gmake[3]: *** [/usr/obj/ports/firefox-75.0beta2/firefox-75.0/config/makefiles/rust.mk:287: force-cargo-library-build] Error 101
gmake[3]: Leaving directory '/usr/obj/ports/firefox-75.0beta2/build-amd64/toolkit/library/rust'                                            
gmake[2]: *** [/usr/obj/ports/firefox-75.0beta2/firefox-75.0/config/recurse.mk:74: toolkit/library/rust/target] Error 2                    
gmake[2]: *** Waiting for unfinished jobs....

fetching locally the file allows the build to go further, i'll see if there are other occurences..

Regressed by: 1620854
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED

It would have been nice to use --exclude-vcs instead but not all versions of tar has that option (needs to be at least 1.29) and even then would still have to add a few more to the list of files. Quoting from their manual page (https://www.gnu.org/software/tar/manual/html_node/exclude.html):
As of version 1.32, the following files are excluded:

`CVS/', and everything under it
`RCS/', and everything under it
`SCCS/', and everything under it
`.git/', and everything under it
`.gitignore'
`.gitmodules'
`.gitattributes'
`.cvsignore'
`.svn/', and everything under it
`.arch-ids/', and everything under it
`{arch}/', and everything under it
`=RELEASE-ID'
`=meta-update'
`=update'
`.bzr'
`.bzrignore'
`.bzrtags'
`.hg'
`.hgignore'
`.hgrags'
`_darcs'
See Also: → 1621597

Comment on attachment 9132516 [details]
Bug 1621564 - 75.0beta source tarballs dont contain third_party/rust/failure/.github-ci.yml -> failure to build r=froydnj

Beta/Release Uplift Approval Request

  • User impact if declined: Users cannot build from source tarballs
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Download source tarball and attempt to build from it
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky, but alternative is to back out Bug 1620854 from beta
  • String changes made/needed: none
Attachment #9132516 - Flags: approval-mozilla-beta?
Flags: qe-verify+

What's the practical difference between this and the backout, in terms of what ends up in the tarball?

Flags: needinfo?(iann_bugzilla)
Pushed by iann_cvs@blueyonder.co.uk:
https://hg.mozilla.org/integration/autoland/rev/bdc7ba8af4bf
75.0beta source tarballs dont contain third_party/rust/failure/.github-ci.yml -> failure to build r=froydnj

(In reply to Julien Cristau [:jcristau] from comment #5)

What's the practical difference between this and the backout, in terms of what ends up in the tarball?

With the backout there would still be .git vcs files in the tarball.

Flags: needinfo?(iann_bugzilla)

(In reply to Ian Neal from comment #7)

(In reply to Julien Cristau [:jcristau] from comment #5)

What's the practical difference between this and the backout, in terms of what ends up in the tarball?

With the backout there would still be .git vcs files in the tarball.

And that's a problem because?

For the beta I don't think it matters whether the original patch is backed out or this patch is applied.
For trunk, I think it is better to exclude files that are not needed from the tarball.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Duplicate of this bug: 1621926

Comment on attachment 9132516 [details]
Bug 1621564 - 75.0beta source tarballs dont contain third_party/rust/failure/.github-ci.yml -> failure to build r=froydnj

I'll get bug 1620854 backed out of 75 instead. Thanks.

Attachment #9132516 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Unfortunately we as manual QA don't have the resources and environment to cover this at the time. I will remove the qe-verify+ flag since that's specific for our team. Let me know if this is of very high importance and would truly benefit from manual verification and then we can accommodate it.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.