Closed Bug 1621818 Opened 9 months ago Closed 8 months ago

PiP + Nightly + WebRender + Iframes - [GFX1-]: Failed to connect WebRenderBridgeChild and I can't click in PiP button inside an iframe

Categories

(Toolkit :: Video/Audio Controls, defect)

76 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1575868

People

(Reporter: wtds.trabalho, Unassigned)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

  • Activate WebRender flags
  • Open Twitter
  • See post with Youtube video inside iframe
  • Try to launch PiP modal from PiP button
  • Can't open and get that error in browser console:
    [GFX1-]: Failed to connect WebRenderBridgeChild.

Example(Click to play):
https://twitter.com/felipeneto/status/1237879408817344515

Actual results:

  • Can't open PiP modal from youtube video inside Twitter page
  • Maybe problem with PiP and WebRender and iframes

GFX1-]: Failed to connect WebRenderBridgeChild

Expected results:

No problems. PiP working together with webRender.
PiP launch from videos inside twitter post using Webrender.

Thanks!

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Graphics: WebRender
Product: Firefox → Core

I can see the PiP button but I can't click

Summary: PiP + Nightly + WebRender + Iframes - [GFX1-]: Failed to connect WebRenderBridgeChild → PiP + Nightly + WebRender + Iframes - [GFX1-]: Failed to connect WebRenderBridgeChild and I can't click in PiP button inside an iframe

This is working for me (Linux, d2ac41047c10 2020-03-07), but that's calling itself 75.0, so I'll get a more recent build and see if I can reproduce then.

Okay, I've tried this with 76.0a1 (2020-03-14) (64-bit) Linux WebRender, and the PiP stuff works fine for me on the Olhar Digital page.

Wellington, can you visit about:support, click "Copy text to clipboard", and paste that into this bug?

Also, can you try reproducing the problem with a fresh profile? Run Firefox passing the -ProfileManager flag, and it should be clear how to create a new profile. https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Multiple_profiles#Profile_management

Flags: needinfo?(wtds.trabalho)
Flags: needinfo?(wtds.trabalho) → needinfo?(jimb)
Attached file About:support output

Looking at the about:support, it looks like Fission is enabled. Picture-in-Picture currently doesn't work correctly on some sites when Fission is enabled. That work is being tracked in bug 1575868.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Component: Graphics: WebRender → Video/Audio Controls
Flags: needinfo?(jimb)
Product: Core → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 1575868
You need to log in before you can comment on or make changes to this bug.