Closed Bug 1622195 Opened 8 months ago Closed 7 months ago

Check default browser modal blocks action on Search Tips

Categories

(Firefox :: Address Bar, defect, P1)

Desktop
All
defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 76
Iteration:
76.1 - Mar 9 - Mar 22
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- disabled
firefox75 --- verified
firefox76 --- verified

People

(Reporter: aflorinescu, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

[Environment:]

Windows 10
Mac 10.15.3
Ubuntu 16804

[Versions:]

75.0b3 20200313021419
76.0a1 20200312215313

[Steps:]
  1. Open Firefox with a new profile && browser is not default.
  2. Enable browserconsole.
  3. Open browser console and use the following snippet to modify the profile age:
  • (async function() { let { ProfileAge } = ChromeUtils.import("resource://gre/modules/ProfileAge.jsm"); let age = await ProfileAge(); age._times = { firstUse: 1368255600000, created: 1368255600000 }; await age.writeTimes(); })(); *
  1. Close the browser console.
  2. Close and reopen the browser.
[Actual Result:]

As the browser is not the default one, the check_default_browser modal will be shown at the start-up while also the Search Tips are shown.
When the modal is actioned upon, the Search Tip is temporarily dismissed.

[Expected Result:]

The optimal user experience would be to show the Search Tips when we're certain that there is nothing that blocks it or obscures it, in order to offer the user the desired actionable choice.

[Note:]

Even though in this particular case, the Search Tips has been already loaded but is just not actionable and only readable-> there might be other cases similar to this one, but QA doesn't have a list with browser level modal/non-modal notifications with might have impact on Search Tips. (any hint/idea would be apreciated)

See Also: → 1622214

Verdi called out the default-browser prompt in particular his spec: If it's shown, then we shouldn't show a tip. afaict the implementation is correct: We don't show the tip if the prompt is first shown. But this bug is that the tip is shown first and then the prompt, right Adrian?

I'm not sure what we can do to mitigate that, but we should take a look to see if we can detect that case. Or maybe at least don't close the tip after the prompt is closed.

Since this is related to the something that's called out in the spec, and it affects people coming to Firefox for the first time, I'll mark this a P1.

Points: --- → 3
Priority: -- → P1
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 76.1 - Mar 9 - Mar 22
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9f1a3e400f83
Disable Search Tips if the default browser prompt will be shown. r=adw
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
See Also: → 1624044
Regressions: 1624044
Regressions: 1624152

The patch landed in nightly and beta is affected.
:harry, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.
If yes, don't forget to request an uplift for the patches in the regressions caused by this fix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(htwyford)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Comment on attachment 9133667 [details]
Bug 1622195 - Disable Search Tips if the default browser prompt will be shown. r?adw

Beta/Release Uplift Approval Request

  • User impact if declined: Users would encounter the poor UI shown in comment 1, with multiple notification-type dialogs asking for their attention. This is more pressing because one of the dialogs in conflict is the default browser prompt, so this affects new users disproportionately.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0.

At the end of the steps, no Search Tip should be shown, only the default browser prompt. Click "Set Default Browser" on the prompt and then repeat the steps (except making a new profile). On the next startup, only the Search Tip should be shown.

  • List of other uplifts needed: Bug 1624044
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch touches the default browser prompt, and Urlbar Search Tips. The Search Tips changes are self-contained and are unlikely to cause issues anywhere else. As for the changes to the default browser prompt, this has baked for a few days so I think the issues have already come out. Regressions in bug 1624044 and bug 1624152 were fixed with a patch in 1624044 (they had the same root cause).

I answered "No" to automated tests above, but both Search Tips and the default browser prompt are still covered by lots of tests; there's just no test for this specific issue since that would require the test to restart the browser.

  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9133667 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9133667 [details]
Bug 1622195 - Disable Search Tips if the default browser prompt will be shown. r?adw

fix interaction between search tips and default browser check, approved for 75 rc1

Attachment #9133667 - Flags: approval-mozilla-beta? → approval-mozilla-release+

To sumarize, the check browser modal blocks the Search tips, as expected. It will show the tips on new tab in the same session. Also, on disabling check or setting browser as default, the search tips will be shown @ startup.

Tested on:
Windows 10, Mac 10.13 and Ubuntu 18.04

using:
75.0 20200403170909 (RC3)
76.0a1 20200405212522

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.