Closed Bug 1622409 Opened 8 months ago Closed 7 months ago

Put FTP code behind a pref

Categories

(Core :: Networking: FTP, task, P2)

task
Points:
1

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: nhi, Assigned: michal)

References

(Blocks 2 open bugs, Regressed 1 open bug)

Details

(Keywords: dev-doc-complete, site-compat, Whiteboard: [necko-triaged])

Attachments

(1 file)

No description provided.
Assignee: nobody → michal.novotny
Blocks: kill-ftp
Points: --- → 1
Priority: -- → P2
Whiteboard: [necko-triaged]
Blocks: 1622410

https://developer.mozilla.org/en-US/docs/Web/API/Navigator/registerProtocolHandler#Permitted_schemes
ftp://, ftps:// and sftp:// should be added to this list. With network.ftp.enabled;false Firefox should ask the user which application should be used for the given protocol. (Click here for an example: ircs://example)

Duplicate of this bug: 1568640
Keywords: site-compat
Keywords: dev-doc-needed

FTP will be turned off for Nightly, and on for release for now.

Disables FTP protocol handler on nightly. FTP scheme is handled by external protocol handler if it isn't explicitly disabled with preference network.protocol-handler.external.ftp = false.

See Also: → 1626365

This could land now.

Flags: needinfo?(michal.novotny)
Pushed by mnovotny@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8489f281f78
Put FTP code behind a pref r=marionette-reviewers,valentin,whimboo,mixedpuppy
Flags: needinfo?(michal.novotny)
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Blocks: COVID-19

For now, I think that all there is to do on MDN for this change, is to add an entry to the Experimental features page: https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#Security. Let me know if you think this needs something else.

Regressions: 1667468
You need to log in before you can comment on or make changes to this bug.