Closed Bug 1626365 Opened 1 year ago Closed 1 month ago

FTP removal and testing with addons

Categories

(WebExtensions :: General, task, P2)

task

Tracking

(firefox88 fixed)

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 2 open bugs, )

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

This meta is intended to block disabling FTP being turned off beyond Nightly until we have resolved any questions or issues resulting from the removal. The google doc listed in the url field is a WIP document to outline any potential issues and questions.

Specifically, FTP is being disabled on Nightly in Bug 1622409

Once I organize my thoughts better and verify some things we'll make the document public.

Depends on: 1626415
Depends on: 1626424

Some useful notes that may end up as other bugs:

FTP: there are some other mentions in the documentation:

browserSettings.ftpProtocolEnabled - will be removed or deprecated?
Proxy.settings as an FTP property - will be removed or deprecated?
tabs.executeScript() notes that you can inject code from an FTP source - Remove?
proxy.register() (deprecated) notes that it will be called for any FTP request - Remove?
tabs.insertCSS() notes that the CSS can be from an FTP source - Remove?
Work with the Bookmarks API notes that you can bookmark an FTP site - will still be valid?
events.UrlFilter uses an FTP address is an example of matched URLs (urlMatches) - removed to avoid confusion?

should allow ftp in protocol handlers when this happens.

Remove the ability for extensions to toggle ftp support on, and add protocol handler support.

Assignee: nobody → mixedpuppy
Status: NEW → ASSIGNED
Keywords: meta
Summary: [meta] FTP removal and testing with addons → FTP removal and testing with addons
No longer depends on: 1626415
Duplicate of this bug: 1626415
No longer depends on: 1626424
Duplicate of this bug: 1626424
Blocks: 1699222
Keywords: dev-doc-needed
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bcdf1f609632
better extension support for ftp removal r=robwu
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Hi Shane,
I've started docs for this in on MDN content and Browser compatibility.
Currently this covers making browserSettings.ftpProtocolEnabled readonly.

This also mentions that you added "better extension support". What does that mean for an extension developer? What else can they do/where are you expecting docs?

In https://bugzilla.mozilla.org/show_bug.cgi?id=1626365#c2 you mention all these things which might change - did they, and if so how? For example can we still bookmark an FTP URL. If nothing has changed I'll leave the docs alone.

browserSettings.ftpProtocolEnabled - will be removed or deprecated?
Proxy.settings as an FTP property - will be removed or deprecated?
tabs.executeScript() notes that you can inject code from an FTP source - Remove?
proxy.register() (deprecated) notes that it will be called for any FTP request - Remove?
tabs.insertCSS() notes that the CSS can be from an FTP source - Remove?
Work with the Bookmarks API notes that you can bookmark an FTP site - will still be valid?
events.UrlFilter uses an FTP address is an example of matched URLs (urlMatches) - removed to avoid confusion?

Did any of them?

Flags: needinfo?(mixedpuppy)

(In reply to Hamish Willee from comment #9)

Hi Shane,
I've started docs for this in on MDN content and Browser compatibility.
Currently this covers making browserSettings.ftpProtocolEnabled readonly.

This also mentions that you added "better extension support". What does that mean for an extension developer? What else can they do/where are you expecting docs?

"ftp" has been added to protocol_handlers, see list for protocol at https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/protocol_handlers

In https://bugzilla.mozilla.org/show_bug.cgi?id=1626365#c2 you mention all these things which might change - did they, and if so how? For example can we still bookmark an FTP URL. If nothing has changed I'll leave the docs alone.

It may be able to be bookmarked, but would no longer load in Firefox.

browserSettings.ftpProtocolEnabled - will be removed or deprecated?

Setting the value is removed, but addons can still read the value.

Proxy.settings as an FTP property - will be removed or deprecated?
tabs.executeScript() notes that you can inject code from an FTP source - Remove?
proxy.register() (deprecated) notes that it will be called for any FTP request - Remove?
tabs.insertCSS() notes that the CSS can be from an FTP source - Remove?
Work with the Bookmarks API notes that you can bookmark an FTP site - will still be valid?
events.UrlFilter uses an FTP address is an example of matched URLs (urlMatches) - removed to avoid confusion?

Using ftp with any of these will no longer have any effect.

Flags: needinfo?(mixedpuppy)

Thanks Shane. I've fixed these up (mostly by removing the references) in https://github.com/mdn/content/pull/3868

Docs complete for this change; see https://github.com/mdn/content/issues/3462 for the discussion.

You need to log in before you can comment on or make changes to this bug.