Closed Bug 1622703 Opened 7 months ago Closed 4 months ago

Check which new Firefox enterprise policies we should have for 78

Categories

(Thunderbird :: General, task, P1)

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 78.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

It's been quite a while since we first copied Firefox's enterprise policies. Richard's ported some of the newer ones, but there's quite a lot of things they have that we don't have.

Priority: -- → P1
Summary: Check which new Firefox enterprise policies we should have → Check which new Firefox enterprise policies we should have for 78
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attached patch 1622703-enterprise-78-1.diff (obsolete) — Splinter Review
Attachment #9152024 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9152024 [details] [diff] [review]
1622703-enterprise-78-1.diff

Review of attachment 9152024 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/components/enterprisepolicies/schemas/policies-schema.json
@@ +315,5 @@
> +        },
> +        "browser.places.importBookmarksHTML": {
> +          "type": "boolean"
> +        },
> +        "browser.bookmarks.restore_default_bookmarks": {

hmm, some of these are really quite irrelevant to tb
maybe we should skip the bookmarks stuff at least

@@ +332,5 @@
> +          "type": "boolean"
> +        },
> +        "browser.safebrowsing.malware.enabled": {
> +          "type": "boolean"
> +        },

maybe these too
Attachment #9152024 - Flags: review?(mkmelin+mozilla) → review+

Actually, there's a lot of those that shouldn't be there, because they either do nothing in Thunderbird or we're using them to explicitly turn features off. I think I started going through them for this patch, then gave up and copied them all across. I'll prune them again properly before landing.

I've had to make some changes as some of the preferences tab pieces really weren't ready.

Attachment #9152024 - Attachment is obsolete: true
Attachment #9152624 - Flags: review+

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b10f1799da16
Copy new enterprise policies from Firefox. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 78.0

Hi Geoff.

This line in the patch (privacy.js):

exceptionsButton.disabled = !acceptCookies || cookieBehaviorLocked;

Was there a specific reason for including acceptCookies in here? I think this causes bug 1659335.

Flags: needinfo?(geoff)

I only vaguely recall doing this, but at a guess I'd say I didn't account for adding an exception that allows cookies when the default is not to.

Flags: needinfo?(geoff)
Regressions: 1659335
You need to log in before you can comment on or make changes to this bug.