Closed Bug 1623395 Opened 5 months ago Closed 5 months ago

Wrong preview for HTTP requests in the Console panel

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(firefox-esr68 unaffected, firefox74 unaffected, firefox75 unaffected, firefox76 verified)

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- verified

People

(Reporter: Honza, Assigned: bomsy)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image image.png

This is likely a regression caused by bug 1613885

STR

  1. Open DevTools and select the Console panel
  2. http://janodvarko.cz/xhr-spy/
  3. Click the Get normal JSON button on the page
  4. Expand the request in the Console panel & Select the Response panel

AR:

  • missing vertical scrollbar
  • smaller height of the preview

ER

  • the same as before (compare with Beta/Release) See my screenshot

Honza

Hubert, can you please look at this, thanks!

Honza

Flags: needinfo?(hmanilla)
Assignee: nobody → hmanilla
Status: NEW → ASSIGNED
Flags: needinfo?(hmanilla)
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aea3c8ce3ff8
Set the height of the response panel in the console r=Honza,nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
QA Whiteboard: [qa-76b-p2]

Confirmed issue with on 76.0a1 (2020-03-18) Windows 10.
Fix verified with 76.0 on Windows 10, macOS 10.15, Ubuntu 18.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.