Closed Bug 1623666 Opened 10 months ago Closed 8 months ago

Always show activity stream top sites in the address bar dropdown

Categories

(Firefox :: Address Bar, enhancement, P2)

enhancement
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox78 --- fixed

People

(Reporter: verdi, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We decided to always show top sites in the address bar dropdown regardless of whether top sites are shown on the new tab page. The problem is that if top sites are not show on the new tab page we don't have access to that list and instead we show the old history list. If possible we should find a way to access the activity stream top site list for display in the address bar even when they are not shown on the new tab page. This way the sites shown with the feature always come from the same data source and enables users to have control over them.

Points: --- → 3
Priority: -- → P2
Depends on: 1617345
See Also: → 1627858
Depends on: 1627858
No longer depends on: 1627858
See Also: 1627858

(In reply to Verdi [:verdi] Best to slack me from comment #0)

We decided to always show top sites in the address bar dropdown regardless of whether top sites are shown on the new tab page. The problem is that if top sites are not show on the new tab page we don't have access to that list and instead we show the old history list. If possible we should find a way to access the activity stream top site list for display in the address bar even when they are not shown on the new tab page. This way the sites shown with the feature always come from the same data source and enables users to have control over them.

What about users who aren't interested in "top sites"?
Personally, I don't want to see them either on a new tab OR when I focus on the address field.

Blocks: 1630275
No longer blocks: urlbar-update-1
Blocks: 1627858
Depends on: 1634279
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 78.2 - May 18 - May 31
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/82c5e2ef41df
Always show Top Sites in the Urlbar on empty searches. r=dao
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
See Also: → 1572329
You need to log in before you can comment on or make changes to this bug.