Closed Bug 1627858 Opened 7 months ago Closed 5 months ago

Should have a user visible preference in about:preferences to disable Top Sites on focus

Categories

(Firefox :: Address Bar, enhancement, P1)

75 Branch
enhancement
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox78 --- fixed

People

(Reporter: yoasif, Assigned: harry)

References

(Blocks 1 open bug)

Details

(Keywords: blocked-ux, losing-users, parity-safari)

Attachments

(4 files)

Given some of the plans around more features being added to megabar (eg bug 1623666), it'd be nice to have a user visible preference to control some of the magical features.

Top Sites on about:home can be controlled by about:preferences, but no corresponding preference exists for browser.urlbar.openViewOnFocus. It would be nice to make this user visible in order to cater to users who want a more legacy appearance, or who would prefer to not show their top sites on screencasts (for example).

For the privacy argument, see:

https://www.reddit.com/r/firefox/comments/fw4tc2/controll_in_firefox_750/
https://www.reddit.com/r/firefox/comments/fw485c/oh_wow_the_new_url_bar_is_absolutely_atrocious_in/

See Also: → 1623666

Thanks for reporting.

Re: unwanted disclosures during live events and/or recording, I recall (from participation in AppleSeed) that Apple made a comparable mistake years ago with Safari in Mac OS X.

I can't recall whether, or how, Apple resolved the issue (and I don't have macOS in a virtual machine, to tell).

Safari has a user visible preference to show Favorites (essentially the equivalent to Top Sites in megabar) in the "Search" preference.

Keywords: parity-safari
Blocks: 1623666
No longer blocks: 1623666
See Also: 1623666
Blocks: urlbar-update-1
No longer blocks: urlbar-update-3
Keywords: blocked-ux

If we ever add a pref to disable automatically showing Top Sites, it should not be openViewOnFocus, that pref is not intended to stay long term as it controls the whole "reopen" behavior, not just Top Sites.

Summary: browser.urlbar.openViewOnFocus should have a user visible preference in about:preferences → Should have a user visible preference in about:preferences to disable Top Sites on focus

I think having an option for openViewOnFocus is necessary as well. For example, when people intend to copy the current url they do so by selecting the address either by click + Ctrl-C or by right-click which opens the context menu to do so. Because every browser and every text field ever has worked that way.

Now I know there is a page action to do the copying but it's not "familiar", and it's worse UX because accessing it from page-action menu is slow and having it always visible wastes space. And, people don't even look for such thing as they expect the typical behavior.

Having the results appear when selecting is very unnecessary distraction when copying url, and like mentioned earlier there is a privacy issue as well.

I don't think that there needs to be a separate option for "show top sites on focus" and "open the popup on focus" since, if the "show top sites" is disabled, then what are you gonna show there anyway? But the user should absolutely have an option to select whether they want to open the popup when interacting with urlbar.

(In reply to jastekken from comment #4)

I don't think that there needs to be a separate option for "show top sites on focus" and "open the popup on focus" since, if the "show top sites" is disabled, then what are you gonna show there anyway?

What is showed in 75 when browser.urlbar.update1 is set to false when clicking old dropdown button, and what was showed by default in 74. Most frequently typed urls I think? I tried to explain in Bug 1628024

I raised Control-L in Firefox 75.0 in Reddit (linked from the opening post here).

(In reply to jastekken from comment #4)

… an option for openViewOnFocus is necessary …

I agree.

Quoting a few users from https://www.reddit.com/r/firefox/comments/fwhlva/address_barawesomebar_design_update_in_firefox_75/:

  • "When I click the address bar I want it to select the url and that's IT! Not open any drawer and certainly not pop up."
  • "I don't want anything to open or pop-up when I click the address bar!"
  • "I absolutely hate it, turned it off months ago in Nightly. They need to put a user friendly setting somewhere to easily turn it off/on in the future."
  • "I really don't think that the search bar should expand unless I have started typing something into it, which is the behavior in Chrome. I just don't like the inconsistency and it bothers my eyes (seriously)"
  • ...

So a preference is a MUST (because of the aforementioned privacy problem) and I guess the dropdown button should be readded.

(In reply to Asif Youssuff from comment #2)

Safari has a user visible preference to show Favorites …

Enabled by default, or disabled by default?

TIA

(In reply to Graham Perrin from comment #8)

(In reply to Asif Youssuff from comment #2)

Safari has a user visible preference to show Favorites …

Enabled by default, or disabled by default?

Enabled by default.

(In reply to Ruben from comment #7)

Quoting a few users from https://www.reddit.com/r/firefox/comments/fwhlva/address_barawesomebar_design_update_in_firefox_75/:

  • "When I click the address bar I want it to select the url and that's IT! Not open any drawer and certainly not pop up."
  • "I don't want anything to open or pop-up when I click the address bar!"
  • "I absolutely hate it, turned it off months ago in Nightly. They need to put a user friendly setting somewhere to easily turn it off/on in the future."
  • "I really don't think that the search bar should expand unless I have started typing something into it, which is the behavior in Chrome. I just don't like the inconsistency and it bothers my eyes (seriously)"
  • ...

So a preference is a MUST (because of the aforementioned privacy problem) and I guess the dropdown button should be readded.

I'll add my preference for retaining the dropdown history button when top sites is not used.

Wonder if it'd be easier to make the "show history" button into one of the items in the address bar's customization palette, so people that want it in the address bar can put it back in there?

(In reply to Wes Kocher (:KWierso) (Not reading bugmail; email directly if needed) from comment #11)

Wonder if it'd be easier to make the "show history" button into one of the items in the address bar's customization palette, so people that want it in the address bar can put it back in there?

Maybe not a dedicated customization item because it's tied to address bar, but it could be a checkbox in either customization view or page-action menu.

But the question then becomes what should that checkbox control. Is it:

  1. open results list when address bar is focused
  2. show top sites instead of <whatever the previous behavior was>

I mean, ideally there would be both options available.

FWIW, the Safari option to "Show Favorites" shows no popup if the user clicks the address bar.

Personally, it seems to me that the previous behavior when clicking the disclosure triangle in the address bar (showing history) and the new behavior of showing Top Sites is mutually exclusive - I can't think of a way that makes sense to allow both to be shown.

Given the thinking in Bug 1623666, it seems that Verdi wants to drop the history entirely from the address bar in favor of Top Sites/activity stream - I know that this will probably annoy people, but I (personally) think it is okay to drop history.

If we do that, we can add a checkbox in the "Address Bar" section of Privacy & Security labeled "Top Sites" that acts like the "Show Favorites" checkbox in Safari:

If it is checked: show top sites when opening the address bar (current behavior)
if it is unchecked: do not show top sites when opening the address bar; show suggestions after the user has typed a query

If we want to retain history (like the old address bar), I think it makes a lot more sense to just bring back the disclosure triangle, like Firefox <75 and current Vivaldi. That way, it retains the same UX it has always had, remains discoverable and can coexist with the new top sites behavior. That requires more thinking though, and is out of scope for what I am suggesting here (File a new bug if you are interested in thinking this through! - I personally never used it.)

(In reply to Asif Youssuff from comment #13)

If we want to retain history (like the old address bar), I think it makes a lot more sense to just bring back the disclosure triangle, like Firefox <75 and current Vivaldi. That way, it retains the same UX it has always had, remains discoverable and can coexist with the new top sites behavior. That requires more thinking though, and is out of scope for what I am suggesting here (File a new bug if you are interested in thinking this through! - I personally never used it.)

See bug 1628024 for letting the user control the content of the megabar dropdown (on initial focus, that is).

Keywords: losing-users
Duplicate of this bug: 1628214
Duplicate of this bug: 1628251
Duplicate of this bug: 1628286

We are evaluating a visible option to control the automatic opening of Top Sites. It should still be possible to open them focusing the field again, like it currently happens on the New Tab page.

Priority: -- → P1

(In reply to Tony Green from comment #19)

This definitely needs an easy option to turn it off.
It's doubly annoying to me as the so-called "top sites" include Google, Amazon and the vile Facebook, all of which are sites I will NEVER use.

why don't you just customize those away from the list?

(In reply to Marco Bonardo [:mak] from comment #20)

(In reply to Tony Green from comment #19)

This definitely needs an easy option to turn it off.
It's doubly annoying to me as the so-called "top sites" include Google, Amazon and the vile Facebook, all of which are sites I will NEVER use.

why don't you just customize those away from the list?

If there's a way to do that, it's as well-hidden as how to disable this irritating behaviour in the first place.

(In reply to Tony Green from comment #22)

If there's a way to do that, it's as well-hidden as how to disable this irritating behaviour in the first place.

Just edit the Top Sites list on about:newTab, it's the same list.

(In reply to Marco Bonardo [:mak] from comment #23)

(In reply to Tony Green from comment #22)

If there's a way to do that, it's as well-hidden as how to disable this irritating behaviour in the first place.

Just edit the Top Sites list on about:newTab, it's the same list.

People(like me) who want an option to purge the "Top" sites from the URL bar are the same people who purge the "Top" site from about:newTab. I wouldn't be against linking the two settings to be honest

(In reply to Marco Bonardo [:mak] from comment #23)

(In reply to Tony Green from comment #22)

If there's a way to do that, it's as well-hidden as how to disable this irritating behaviour in the first place.

Just edit the Top Sites list on about:newTab, it's the same list.

And that's obvious? How many people are going to find that option? It, and the option to turn off this behaviour, should be in the preferences surely.

(In reply to ppikula from comment #24)

People(like me) who want an option to purge the "Top" sites from the URL bar are the same people who purge the "Top" site from about:newTab. I wouldn't be against linking the two settings to be honest

If Top Sites are disabled, the urlbar fallbacks to the old history list.

Depends on: 1627989
Blocks: 1627989
No longer depends on: 1627989

(In reply to Marco Bonardo [:mak] from comment #26)

(In reply to ppikula from comment #24)

People(like me) who want an option to purge the "Top" sites from the URL bar are the same people who purge the "Top" site from about:newTab. I wouldn't be against linking the two settings to be honest

If Top Sites are disabled, the urlbar fallbacks to the old history list.

I can report that I saw odd results (in my case, the first option being "Search With Amazon" even though I had the separate search bar enabled and Amazon was not my default search engine) while using a blank new tab page.

From looking at the options GUI and checking my settings, it seems like it is possible to both have "Top Sites" enabled on Firefox Home, while having both the homepage and new tab pages set to blank. Is it possible that in this scenario the URL bar is seeing Top Sites as enabled and displaying them, but from the user's perspective they are "disabled" because they are never displayed?

(In reply to Aaron Nowack from comment #27)

Is it possible that in this scenario the URL bar is seeing Top Sites as enabled and displaying them, but from the user's perspective they are "disabled" because they are never displayed?

See bug 1628025.

(In reply to Marco Bonardo [:mak] from comment #26)

(In reply to ppikula from comment #24)

People(like me) who want an option to purge the "Top" sites from the URL bar are the same people who purge the "Top" site from about:newTab. I wouldn't be against linking the two settings to be honest

If Top Sites are disabled, the urlbar fallbacks to the old history list.

It doesn't work that way it seems. I have everything disabled on the home page / new tab page + set it to blank and I still get Top Sites in the urlbar.

(In reply to Csaba Bencze from comment #29)

It doesn't work that way it seems. I have everything disabled on the home page / new tab page + set it to blank and I still get Top Sites in the urlbar.

Disabling means going to about:preferences#home and unchecking Top Sites there. Is this what you did?
Note the list will still open automatically, it will just be a slightly different list.

(In reply to Marco Bonardo [:mak] from comment #30)

(In reply to Csaba Bencze from comment #29)

It doesn't work that way it seems. I have everything disabled on the home page / new tab page + set it to blank and I still get Top Sites in the urlbar.

Disabling means going to about:preferences#home and unchecking Top Sites there. Is this what you did?
Note the list will still open automatically, it will just be a slightly different list.

Yes I did that.
I apologize, it is indeed a different list. Almost the same but different order, and a few different entries (at least for me).

Dear Mozilla developers, please be so kind to review the activity diagram I posted as an attachment in bug 1627861. The preference we are talking about in this bug is mentioned in that scheme. That may ease the discussion a bit?

For the idea behind the activity diagram, see comment https://bugzilla.mozilla.org/show_bug.cgi?id=1627861#c24.

Blocks: 1630275
No longer blocks: urlbar-update-1
Blocks: 1628557

If you’re waiting impatiently for this preference, here are some workarounds I found to stop Top Sites from showing (tested on macOS):

  • If you focus the address bar by pressing F6, top sites do not show, unlike when pressing ⌘L (Ctrl-L) or clicking on the address bar.
  • If you just focused the address bar and top sites appeared, and you want to hide them so you can see the page underneath, press the Esc key.

Of course, these are not full solutions. Both workarounds require keypresses or keypress sequences that are slower to execute and less familiar to users than the old ways, and the second workaround still has a privacy risk because top sites will be visible for a moment.

Duplicate of this bug: 1630402
Duplicate of this bug: 1628039
Blocks: 1631845

Engineering spoke with UX about this today. We are going to add a preference to about:preferences#search to control whether Top Sites are shown when the address bar is focused. If the preference is disabled, we will not show any list of favourite/frecent sites in the address bar. We will link to this preference from the address bar results panel in bug 1631845.

We won't be bringing back the old dropmarker/frecent sites list. This is to reduce confusion: since Top Sites can be quite similar to the old list (even identical in some cases!) it could be frustrating to some users who disable a pref to show Top Sites on focus, but then who see a very similar list of sites instead. It might not be clear what the distinction is, or how to control the new behaviour. We considered other behaviour to show frecent sites like showing them after the user clicks an already-expanded address bar or presses the down arrow, like we do on the New Tab Page, but we decided against it. We want to keep this behaviour as straightforward as possible. Users who really want to see their frecent sites list can type ^ in the address bar.

Since there's considerable interest in this bug, I'll add that we have a number of other bugs on file to improve Top Sites behaviour: bug 1631845, bug 1631844, and bug 1631848. Final behaviour is pending a design specification from UX.

(In reply to Harry Twyford [:harry] from comment #39)

We considered other behaviour to show frecent sites like showing them after the user clicks an already-expanded address bar or presses the down arrow, like we do on the New Tab Page, but we decided against it. We want to keep this behaviour as straightforward as possible. Users who really want to see their frecent sites list can type ^ in the address bar.

How is typing ^ more straightforward then keeping the dropmarker and the down arrow? The latter is immediately visible / discoverable, obvious, well known and in muscle memory for many of us, and consistent with the search bar. The former is undiscoverable and inconsistent.

Let me just add that pressing the down arrow is one keypress on a Hungarian keyboard, while typing ^ is three: AltGr+3, Space
(The reason for that is you can type â by doing AltGr+3, A)

Stop making our lives harder. Please.

Just to clarify, the new preference to turn off top sites won't disable the functionality where the address bar will suggest sites as you start typing, right?

(In reply to Nameless Voice from comment #42)

Just to clarify, the new preference to turn off top sites won't disable the functionality where the address bar will suggest sites as you start typing, right?

It will not disable that. It'll only control whether your Top Sites are shown when you focus the address bar, before you type anything.

(In reply to marczellm from comment #41)

(In reply to Harry Twyford [:harry] from comment #39)

We considered other behaviour to show frecent sites like showing them after the user clicks an already-expanded address bar or presses the down arrow, like we do on the New Tab Page, but we decided against it. We want to keep this behaviour as straightforward as possible. Users who really want to see their frecent sites list can type ^ in the address bar.

How is typing ^ more straightforward then keeping the dropmarker and the down arrow? The latter is immediately visible / discoverable, obvious, well known and in muscle memory for many of us, and consistent with the search bar. The former is undiscoverable and inconsistent.

Exactly. That feature is totally new to me.

(In reply to marczellm from comment #41)

(In reply to Harry Twyford [:harry] from comment #39)

We considered other behaviour to show frecent sites like showing them after the user clicks an already-expanded address bar or presses the down arrow, like we do on the New Tab Page, but we decided against it. We want to keep this behaviour as straightforward as possible. Users who really want to see their frecent sites list can type ^ in the address bar.

How is typing ^ more straightforward then keeping the dropmarker and the down arrow?

Consider Top Sites the replacement for the frecent sites list. Top Sites has much of the same content, especially if you do not pin sites to it. The Top Sites list also has the advantage of being customizable. It is also shown in the most straightforward way possible: automatically, when you focus the address bar. One exception to the replacement is the ^ shortcut for the frecent sites list because it doesn't impose much of a maintenance cost.

We're committed to improving address bar Top Sites (see this bug, bug 1631845, bug 1631844, and bug 1631848) to make it an even better replacement.

I find it hard to comprehend the idea that "Top Sites" has anything to do with recent sites.
Before I disabled it, "Top Sites" showed sites such as Amazon and Facebook. And these are sites that I never visit, and would never visit on principle. It was their inclusion which strongly influenced my hostility to this "feature".

(In reply to Harry Twyford [:harry] from comment #39)

We won't be bringing back the old dropmarker/frecent sites list. This is to reduce confusion: since Top Sites can be quite similar to the old list (even identical in some cases!) it could be frustrating to some users who disable a pref to show Top Sites on focus, but then who see a very similar list of sites instead. It might not be clear what the distinction is, or how to control the new behaviour. We considered other behaviour to show frecent sites like showing them after the user clicks an already-expanded address bar or presses the down arrow, like we do on the New Tab Page, but we decided against it. We want to keep this behaviour as straightforward as possible. Users who really want to see their frecent sites list can type ^ in the address bar.

I may duplicate this comment over at Bug 1629387 - but two things to consider if you haven't already:

  1. Top Sites can be populated by users manually - and I would think a design goal of Top Sites in general is to promote and facilitate this. Remember that two "Top Sites" are pinned by default in en-us (or has been) - Amazon and Google searches - which are not at all necessarily frecent. When Top Sites are customized by users, they can differ extensively from the drop marker's frecent url list.
  2. If you already plan to add a toggle to about:preferences#search to enable/disable Top Sites, you could easily have one for the drop marker. Vivaldi includes this as a preference.
  3. I have seen some mockups showing an omnipresent magnifying glass icon near the awesomebar that presumably adds ? to the awesomebar input. The dropmarker could do the same thing for ^. It doesn't seem like that huge a lift for something where developers have given no indication of removing support for ^ -- if it is a supported function, what is the harm in making it discoverable or easily accessible? It could even be disabled by default.

(In reply to Harry Twyford [:harry] from comment #46)

(In reply to marczellm from comment #41)

(In reply to Harry Twyford [:harry] from comment #39)

We considered other behaviour to show frecent sites like showing them after the user clicks an already-expanded address bar or presses the down arrow, like we do on the New Tab Page, but we decided against it. We want to keep this behaviour as straightforward as possible. Users who really want to see their frecent sites list can type ^ in the address bar.

How is typing ^ more straightforward then keeping the dropmarker and the down arrow?

Consider Top Sites the replacement for the frecent sites list. Top Sites has much of the same content, especially if you do not pin sites to it.

But if you do pin sites to it, those pinned sites overtake the recent sites. I’ve got sixteen pinned sites on my new tabs page. The first eight are what show in the dropdown. It never reaches anything that the browser considers a recent site. If Top Sites is a replacement for Recent, then it is doing a poor job.

FWIW, you have access to most frequently visited sites also from the history sidebar (one CTRL+H of distance)

(In reply to Marco Bonardo [:mak] from comment #50)

FWIW, you have access to most frequently visited sites also from the history sidebar (one CTRL+H of distance)

  1. Pressing Ctrl+H and then typing does not then immediately allow up/down arrow keys to navigate the resulting matches, nor does the history sidebar get automatically opened and receive keyboard focus when you press Ctrl+T.

  2. Opening the history sidebar ousts Tree Style Tab, which can take a surprising amount of time to re-initialize its sidebar view and can cause browser jank while doing so.

(In reply to Harry Twyford [:harry] from comment #43)

(In reply to Nameless Voice from comment #42)

Just to clarify, the new preference to turn off top sites won't disable the functionality where the address bar will suggest sites as you start typing, right?

It will not disable that. It'll only control whether your Top Sites are shown when you focus the address bar, before you type anything.

Will this preference also disable Top Sites from showing if you start typing in the address bar but then delete everything and go back to having a blank address bar?

(In reply to danmattera1 from comment #52)

Will this preference also disable Top Sites from showing if you start typing in the address bar but then delete everything and go back to having a blank address bar?

It should.

Points: --- → 3

Here's what we'd like to do. Add a pref under Privacy & Security > Address Bar and change the link-to-search-settings text:
Address Bar
When using the address bar, suggest
[X] Browsing history
[X] Bookmarks
[X] Open tabs
[X] Top sites
Change other search preferences

In addition, we want to change the link-to-privacy-&-security text in Search > Search Suggestions to:
Change preferences for other address bar suggestions

This new Top sites preference should be independent from the preference for the new tab, so unchecking this one only controls what is shown in the address bar. Also, we should remove the old list of frecent sites that is currently displayed here if top sites are off. This way if a user unchecks the address bar top sites pref, the address bar results section will no longer open until they begin typing.

(In reply to Verdi [:verdi] Best to slack me from comment #54)

Here's what we'd like to do. Add a pref under Privacy & Security > Address Bar and change the link-to-search-settings text:
Address Bar
When using the address bar, suggest
[X] Browsing history
[X] Bookmarks
[X] Open tabs
[X] Top sites
Change other search preferences

In addition, we want to change the link-to-privacy-&-security text in Search > Search Suggestions to:
Change preferences for other address bar suggestions

This new Top sites preference should be independent from the preference for the new tab, so unchecking this one only controls what is shown in the address bar. Also, we should remove the old list of frecent sites that is currently displayed here if top sites are off. This way if a user unchecks the address bar top sites pref, the address bar results section will no longer open until they begin typing.

When the user is provided an checkbox-list like that, they will expect that they are making a decision about what content they will be shown in addressbar. None of these checkboxes should change when and how the suggestions are shown.

If there is no separate toggle for "open popup on focus" and I were to disable the checkbox for Top sites in this protoyped option, then I as a user would expect that the popup still opens on focus but it lists open tabs, bookmarks and history.

(In reply to Verdi [:verdi] Best to slack me from comment #54)

Here's what we'd like to do.
...
In addition, we want to change the link-to-privacy-&-security text in Search > Search Suggestions to:
Change preferences for other address bar suggestions

This new Top sites preference should be independent from the preference for the new tab, so unchecking this one only controls what is shown in the address bar. Also, we should remove the old list of frecent sites that is currently displayed here if top sites are off. This way if a user unchecks the address bar top sites pref, the address bar results section will no longer open until they begin typing.

Verdi, this sounds great and exactly what I expected when I opened the bug. Thank you for being responsive!

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 77.2 - Apr 20 - May 3

I realize that this may be out of the scope of this bug, but I don't think there's any that actually address it (please do redirect me if there is, however), but will this prevent the bar from expanding/popping out with topsites/suggestions/whathaveyou when you click on it? I can ignore everything else since I don't really look at bookmarks/favorites/suggestions, but that behavior is irritating.

(In reply to Daniel from comment #58)

will this prevent the bar from expanding/popping out with topsites/suggestions/whathaveyou when you click on it?

Yes, see comment 43.

(In reply to Harry Twyford [:harry] from comment #59)

(In reply to Daniel from comment #58)

will this prevent the bar from expanding/popping out with topsites/suggestions/whathaveyou when you click on it?

Yes, see comment 43.

Neat, tyvm :)

This preference can't be added until bug 1623666 is addressed. Right now, we pull our Top Sites directly from the Top Sites on the new tab page. If the NTP is disabled, or the user unchecked Top Sites in about:preferences#home then we can no longer access an up-to-date list. We need to refactor Top Sites in some way so that they're always current regardless of whether they're enabled on the NTP.

If we added this preference without first addressing bug 1623666, then the user could get in a situation where Top Sites are disabled on the NTP but enabled in the address bar. They'd only ever see an out-of-date list that never updates.

Iteration: 77.2 - Apr 20 - May 3 → ---
Depends on: 1623666

(In reply to Harry Twyford [:harry] from comment #61)

If the NTP is disabled, or the user unchecked Top Sites in about:preferences#home then we can no longer access an up-to-date list. We need to refactor Top Sites in some way so that they're always current regardless of whether they're enabled on the NTP.

If we added this preference without first addressing bug 1623666, then the user could get in a situation where Top Sites are disabled on the NTP but enabled in the address bar. They'd only ever see an out-of-date list that never updates.

What happens in this situation if a user has pinned sites in Top Sites (like happens by default), then never uses or disables Top Sites on NTP. Do the pinned sites appear after bug 1623666 is fixed?

Yes, once bug 1623666 is fixed, the same list of Top Sites will be generated regardless of whether Top Sites are disabled on NTP or in the address bar. The NTP/address bar prefs will control whether they are shown.

Note that bug 1631844 should land today and will indicate to users which sites are pinned.

Harry, glad bug 1631844 is going to land, but bug 1631845 won't, and it isn't clear to me that users will know how to remove a pin even if bug 1631844 indicates that the entry is pinned.

I think that ignores a larger problem, though - if the user is not using the Top Sites feature in about:home, why would they care about pins at all?

If bug 1623666 needs to happen, I think it needs to take into consideration whether Top Sites or about:home is enabled - and if not, pins and reordering of items on about:home is meaningless and it just needs to be based solely on historical data.

See Also: → 1571591
No longer blocks: 1628557
Blocks: 1627499

Marco can you confirm that solving of this bug will also allow to disable ugly style of popup? I mean when address bar is overlapped by popup.

I just updated Developer Edition and now I cannot normally use it. It makes me crazy because very annoying and ugly.

Is "Top Sites" the name for this strange popup opening after click (instead of old-style address bar and popup)?

As I mentioned here (https://bugzilla.mozilla.org/show_bug.cgi?id=1633282) we cannot disable this behaviour anymore.

Solving this bug won't open the results panel, the focus style of the urlbar stays the same as it is now when the results panel is closed

This is blocked by bug 1634279 (by way of bug 1623666). I'll be working on 1634279 soon, and will do this right after.

Iteration: --- → 78.2 - May 18 - May 31
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8020ac750ac
Add a user visible preference to disable Top Sites on focus. r=dao,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Regressions: 1641888
Depends on: 1642183

Thanks a lot implementation and release! (Landed to aurora channel update right now.)

browser.urlbar.suggest.topsites in about:config / prefs.js.

Options > Privacy and Security > Address Bar > "When using address bar, suggest:" [...] - ☐ Top sites in about:preferences#privacy

Is there any thought of migrating a customized value of

browser.urlbar.openViewOnFocus = false

to

browser.urlbar.suggest.topsites = false

during upgrade?

It probably would avoid numerous support questions but perhaps it is not enough users to justify the work.

Is it available in current Nightly 790a1 ?

I still see this ugly address bar (https://ibb.co/YZnGXBg).

And my issue https://bugzilla.mozilla.org/show_bug.cgi?id=1633282 was closed in favor of this one.

Blocks: 1643154

(In reply to jscher2000 from comment #72)

Is there any thought of migrating a customized value of

browser.urlbar.openViewOnFocus = false

to

browser.urlbar.suggest.topsites = false

during upgrade?

I filed bug 1643154.

(In reply to Maxim from comment #73)

Is it available in current Nightly 790a1 ?

Yes, this pref is available in 79. See comment 71 for details on how to access it.

I still see this ugly address bar (https://ibb.co/YZnGXBg).

And my issue https://bugzilla.mozilla.org/show_bug.cgi?id=1633282 was closed in favor of this one.

This bug does not change the look of the address bar and we have no plans to do so. Your bug was duped to this one since auto-expanding Top Sites were a common user complaint with the new address bar.

Is there any reason for this to be totally inconsistent with the other .suggest-prefs?

Why do users have to give up the view opening on focus when disabling topsites? I'd like to disable topsites, but also quickly access my frecents (optimally the tab/current url related frecents) on focus.

If this is truly the intended behavior, please rename the pref to browser.urlbar.suggest.topsites.and.open.on.focus or similar and fix the description in about:preferences. There is no indication there that this also disables the popup behavior, needlessly confusing users as to why their urlbar is broken now.

Johannes, see bug 1629387.

That doesn't encompass not having (pinned) topsites at all in the urlbar, the pref itself being inconsistent, and the UX issues of the about:preferences checkbox introduced in this bug. I don't see how a check box "Top sites" under the sentence "When using the address bar, suggest" conveys the information: "Unchecking this will remove topsites from the suggestions and prevent suggestions from appearing at all on focus". I can guarantee you that if this hits release in this state, there's gonna be another outcry of users that are at best, confused that this new option does not actually do what it says it does, and at worst, will accuse Mozilla of being actively misleading.

Johannes, the frecent sites dropmarker was removed alongside the introduction of the top sites feature, and the frecent sites list was essentially deprecated. Bug 1629387 is about bringing that list back in some way.

I can guarantee you that if this hits release in this state, there's gonna be another outcry of users that are at best, confused that this new option does not actually do what it says it does, and at worst, will accuse Mozilla of being actively misleading.

I don't know, I just tried Firefox 68 and I don't see the frecent list on focus, I see it on clicking the drop marker.

Attached image suggest_no_topsites.png

I'm already CC'ed to 1629387 (which has been stale for two months).
Regarding the dropdown on-focus: I may genuinely misremember, because it was pretty much muscle-memory, so I may have actually used the dropmarker in the past.

But I commented here mainly because I don't see how the checkbox in question, as seen in the attached image, conveys to a, possibly new, user of Firefox the semantic meaning:

"Unchecking this will remove topsites from the suggestions and prevent suggestions from appearing at all on focus"

See Also: 1571591
Duplicate of this bug: 1571591

Firefox support page (https://support.mozilla.org/en-US/kb/search-firefox-address-bar) says: "If you’ve turned off Top Sites in your New Tab settings, the address bar will show sites from your history instead". I always have Top Sites disabled so why Firefox suggest it to me now on 78 version? Image attached.

That support page is out-of-date. Thanks for finding it. I submitted an edited version of the support page which should be live soon.

(In reply to Avlasenko Vitaliy from comment #84)

I always have Top Sites disabled so why Firefox suggest it to me now on 78 version? Image attached.

Starting in Firefox 78, Top Sites appear in the address bar independently of whether they appear on the New Tab Page. You can disable them in the address bar with the preference in comment 71.

You need to log in before you can comment on or make changes to this bug.