Location bar URL completion could search names/titles of bookmarks and history items

RESOLVED FIXED in Camino2.1

Status

Camino Graveyard
Location Bar & Autocomplete
P4
enhancement
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Gary Yuen, Assigned: Dan Weber)

Tracking

unspecified
Camino2.1
All
Mac OS X

Details

Attachments

(1 attachment, 2 obsolete attachments)

4.52 KB, patch
Stuart Morgan
: review+
Mike Pinkerton (not reading bugmail)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Address completion could search bookmarks and thus become bookmark completion or
another way to select a bookmark.

Comment 1

16 years ago
Does Mozilla already offer this capability? If not, it might be best to
request/create it there first.

Comment 2

16 years ago
Gary, would this be a dupe of bug 159497?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

16 years ago
this would be a different type of request. Shortcuts or aliases like galeon are
nice but a bookmark  search/completion like a url history completion already
there would be nice.  So if I started to type goo and there was a bookmark
titled google, it would complete it like url histories currently work

Comment 4

16 years ago
Just FYI, IE 5 on Mac OS X does this (and I find it extremly useful).

Comment 5

16 years ago
Seems to be the same as Browser bug 155320
QA Contact: winnie → sairuh
Summary: [RFE] address bar URL completion could search bookmarks → Address bar URL completion could search bookmarks

Comment 6

16 years ago
Dupe of Bug 101642 ? If this gets fixed in the browser do we get it in chimera
automatically?

Re comment #5, no, that deals with adding a used bookmark to the history.
->sfraser. seems similar to an rfe i filed to add quicksearch to the bookmarks
(and history) sidebar...
Assignee: saari → sfraser

Comment 8

16 years ago
Just to be completely clear, this bug is to add the Name of all of your
bookmarks to the list of autocompletion shortcuts/names/whatever.
Autocompleting based on the URL of the bookmark is Bug 166288

Comment 9

15 years ago
Then isn't this bug a duplicate of Bug 166288?

Comment 10

15 years ago
updating summary to clarify differnce.
Summary: Address bar URL completion could search bookmarks → Address bar URL completion could search bookmark names
This seems like something that should be done for 1.0? Is it hard?

Targeting for 1.0, priority 4.
Priority: -- → P4
Target Milestone: --- → Camino1.0
*** Bug 190184 has been marked as a duplicate of this bug. ***
Do we want it to complete from page titles in history, too?

Will there be any user control in this (autocomplete from urls only,
autocomplete from page/bookmark titles only, autocomplete from both)?  I'm not
fond of autocompleting from bookmark/page titles, but it's not a big issue.

Finally, FYI, Camino's own bug to autocomplete from bookmark *URLs* (Bug 166288)
was duped against trunk bug 101642, which is currently assigned to no one...
Component: Bookmarks → Location Bar & Autocomplete

Comment 14

13 years ago
It's a good idea to fix the bug on the trunk instead writing our own
implementation. We might want to write a patch against the 1.8 branch and port
the patch to the trunk later.

Comment 15

13 years ago
(In reply to comment #14)
> It's a good idea to fix the bug on the trunk instead writing our own
> implementation.

We can't share with FF (if that's what you mean) because our bookmarks impl is
different.

> We might want to write a patch against the 1.8 branch and port
> the patch to the trunk later.

The camino code is almost identical between the trunk and branch at the moment.
Simon, is there any chance this will be ready by 1.0?
no way this can make 1.0
Target Milestone: Camino1.0 → Camino1.1
QA Contact: bugzilla → location.bar
Summary: Address bar URL completion could search bookmark names → Address bar URL completion could search bookmark names/titles
Assignee: sfraser_bugs → nobody
Target Milestone: Camino1.1 → Camino1.2
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
Target Milestone: Camino1.6 → ---
(Assignee)

Comment 19

9 years ago
Created attachment 389027 [details] [diff] [review]
Patch 1
Attachment #389027 - Flags: review?(stuart.morgan+bugzilla)

Comment 20

9 years ago
Comment on attachment 389027 [details] [diff] [review]
Patch 1

I'm pretty sure we want to do word-prefix matching, rather than arbitrary substring matching, for this to feel right. (Specifically, I think just a predicate starting with \b is probably enough; we could get really fancy and tokenize, but let's wait and see if that seems worthwhile after using the simpler form for a while.)

Codewise this looks good though if people disagree with me though :)
Attachment #389027 - Flags: review?(stuart.morgan+bugzilla) → review-
(Assignee)

Comment 21

9 years ago
Created attachment 389195 [details] [diff] [review]
Patch 2

Based on my own personal use, I think it is useful to be able to type in an arbitrary word you remember from a title and have that match. However, I don't think that a tokenized search like Firefox 3 uses is all that useful. I'm not going to type more than one word--or more than a couple letters--to find the right URL. Anyway, patch 2 uses an anchored search, so the match has to happen at the beginning of the title.
Attachment #389027 - Attachment is obsolete: true
Attachment #389195 - Flags: review?(stuart.morgan+bugzilla)
(Assignee)

Comment 22

9 years ago
Created attachment 389199 [details] [diff] [review]
Patch 3

Matches search string only if it's at the beginning of a word in the title.
Attachment #389195 - Attachment is obsolete: true
Attachment #389199 - Flags: review?(stuart.morgan+bugzilla)
Attachment #389195 - Flags: review?(stuart.morgan+bugzilla)

Comment 23

9 years ago
Comment on attachment 389199 [details] [diff] [review]
Patch 3

Third time's the charm; r=me
Attachment #389199 - Flags: superreview?(mikepinkerton)
Attachment #389199 - Flags: review?(stuart.morgan+bugzilla)
Attachment #389199 - Flags: review+
Hardware: PowerPC → All
Summary: Address bar URL completion could search bookmark names/titles → Location bar URL completion could search names/titles of bookmarks and history items
Attachment #389199 - Flags: superreview?(mikepinkerton) → superreview+
Landed on cvs trunk.  (This was the 16th oldest open Camino bug.)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Camino2.1
You need to log in before you can comment on or make changes to this bug.