Closed Bug 1624752 Opened 5 months ago Closed 5 months ago

Intermittent forms/input/color/margin-padding-1.html == forms/input/color/margin-padding-1-ref.html | image comparison, max difference: 1, number of differing pixels: 2

Categories

(Core :: Layout: Form Controls, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: emilio)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=294582095&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/LYD_LFS9RSGLOtI_qus9sA/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/LYD_LFS9RSGLOtI_qus9sA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2020-03-24T23:39:38.642Z] 23:39:38 INFO - REFTEST TEST-START | layout/reftests/forms/input/color/margin-padding-1.html == layout/reftests/forms/input/color/margin-padding-1-ref.html
[task 2020-03-24T23:39:38.642Z] 23:39:38 INFO - REFTEST TEST-LOAD | http://10.0.2.2:8854/tests/layout/reftests/forms/input/color/margin-padding-1.html | 844 / 7214 (11%)
[task 2020-03-24T23:39:38.642Z] 23:39:38 INFO - REFTEST TEST-LOAD | http://10.0.2.2:8854/tests/layout/reftests/forms/input/color/margin-padding-1-ref.html | 844 / 7214 (11%)
[task 2020-03-24T23:39:38.642Z] 23:39:38 WARNING - REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/forms/input/color/margin-padding-1.html == layout/reftests/forms/input/color/margin-padding-1-ref.html | image comparison, max difference: 1, number of differing pixels: 2
[task 2020-03-24T23:39:38.652Z] 23:39:38 INFO - REFTEST IMAGE 1 (TEST): data:image/png;base64,
[task 2020-03-24T23:39:38.663Z] 23:39:38 INFO - REFTEST IMAGE 2 (REFERENCE): data:image/png;base64,
[task 2020-03-24T23:39:38.663Z] 23:39:38 INFO - REFTEST INFO | Saved log: START http://10.0.2.2:8854/tests/layout/reftests/forms/input/color/margin-padding-1.html
[task 2020-03-24T23:39:38.663Z] 23:39:38 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
[task 2020-03-24T23:39:38.663Z] 23:39:38 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
[task 2020-03-24T23:39:38.663Z] 23:39:38 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
[task 2020-03-24T23:39:38.664Z] 23:39:38 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
[task 2020-03-24T23:39:38.664Z] 23:39:38 INFO - REFTEST INFO | Saved log: RecordResult fired
[task 2020-03-24T23:39:38.664Z] 23:39:38 INFO - REFTEST INFO | Saved log: START http://10.0.2.2:8854/tests/layout/reftests/forms/input/color/margin-padding-1-ref.html
[task 2020-03-24T23:39:38.664Z] 23:39:38 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
[task 2020-03-24T23:39:38.664Z] 23:39:38 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
[task 2020-03-24T23:39:38.664Z] 23:39:38 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
[task 2020-03-24T23:39:38.666Z] 23:39:38 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
[task 2020-03-24T23:39:38.666Z] 23:39:38 INFO - REFTEST INFO | Saved log: RecordResult fired
[task 2020-03-24T23:39:38.666Z] 23:39:38 INFO - REFTEST TEST-END | layout/reftests/forms/input/color/margin-padding-1.html == layout/reftests/forms/input/color/margin-padding-1-ref.html

:emilio - It looks like bug 1624696 may have caused this regression. Can you have a look?

Flags: needinfo?(emilio)
Regressed by: 1624696

It's a one-pixel difference on the rounded corner, probably due to skia
shenanigans.

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/782f8e872c95
Fuzz an <input type=color> text when non-native theme is enabled.
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Assignee: nobody → emilio
You need to log in before you can comment on or make changes to this bug.