Bug 162479 (xframes)

Implement XFrames

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
17 years ago
a year ago

People

(Reporter: dtomaszuk, Assigned: hjtoi-bugzilla)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Please read: http://www.w3.org/TR/xframes/#status before commenting . If the spec will ever make it, it will take a long time (it doesn't depend on XHTML 2.0), URL)

(Reporter)

Description

17 years ago
Mozilla don't see XFrames (w3c standard)
http://www.w3.org/TR/xframes/

Comment 1

17 years ago
a working draft, not a standard recommandation.

Comment 2

17 years ago
and the draft was first published a week ago.
This is not a bug. Changing severity.

Over to xml, sine the description reads:
"XFrames, an XML application for composing documents together, replacing HTML
Frames."
Assignee: Matti → heikki
Severity: normal → enhancement
Component: Browser-General → XML
QA Contact: asa → petersen
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: other → All
Summary: Mozilla don't see XFrames → Implement XFrames
Target Milestone: --- → Future
alias - for faster searching ;)
Alias: xframes
(Reporter)

Comment 4

17 years ago
So who write patch?

Updated

16 years ago
QA Contact: petersen → rakeshmishra

Updated

16 years ago
Blocks: 161463

Updated

16 years ago
QA Contact: rakeshmishra → ashishbhatt

Comment 5

15 years ago
XFrames was revealed over a year ago.  It'd be really nice for this to be
implemented.

Comment 6

15 years ago
> XFrames was revealed over a year ago.  It'd be really nice for this to be
> implemented.

Note that XFrames is still a WD, not yet a CR. When a specification becomes CR
Mozilla can start implementing it.
(Reporter)

Comment 7

15 years ago
> Note that XFrames is still a WD, not yet a CR. When a specification becomes CR
> Mozilla can start implementing it.
Yes but Steven Pemberton tell that XFrames will not be change in CR (or PR or
REC) so I think that we can start implement this.

Comment 8

15 years ago
(In reply to comment #7)
> Yes but Steven Pemberton tell that XFrames will not be change in CR (or PR or
> REC) so I think that we can start implement this.

Then I suggest WONFTIX, per author of the XFrames document, since the current
draft is highly unstable.
QA Contact: ashshbhatt → ian
From the spec:

# It is inappropriate to use W3C Working Drafts as reference material [...]

...so indeed, we shouldn't implement this until the spec is in CR.
QA Contact: ian → ashshbhatt

Comment 10

15 years ago
(In reply to comment #6)
> > XFrames was revealed over a year ago.  It'd be really nice for this to be
> > implemented.
> 
> Note that XFrames is still a WD, not yet a CR. When a specification becomes CR
> Mozilla can start implementing it.

Obviously, this is true for an implementation that is built by default, but I
think an experimental implementation that isn't built by default would be okay,
since I doubt XFrames is going to change a lot, and it'll just save the
developers work later.  Also, I believe some CSS3 properties were implemented
experimentally (with different names) before they reached CR status, although I
could be wrong.
(Reporter)

Comment 11

15 years ago
XFrames is finished but is not in CR because they wait to XHTML 2.0 REC.

Updated

15 years ago
No longer blocks: 161463
Whiteboard: Please read: http://www.w3.org/TR/xframes/#status . If the specification will ever make it, it will take a long time (it doesn depend on XHTML 2.0)

Updated

15 years ago
Whiteboard: Please read: http://www.w3.org/TR/xframes/#status . If the specification will ever make it, it will take a long time (it doesn depend on XHTML 2.0) → Please read: http://www.w3.org/TR/xframes/#status before commenting . If the spec will ever make it, it will take a long time (it doesn't depend on XHTML 2.0)

Updated

15 years ago
Depends on: 161463

Updated

15 years ago
No longer depends on: 161463

Comment 12

15 years ago
The current "specification" is highly unclear on some things and has many open
issues. It's far from finished.
QA Contact: ashshbhatt → xml

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.