Last Comment Bug 161463 - (xhtml2) XHTML 2.0 tracking
(xhtml2)
: XHTML 2.0 tracking
Status: RESOLVED WONTFIX
: meta, xhtml
Product: Core
Classification: Components
Component: Tracking (show other bugs)
: Trunk
: All All
: -- enhancement with 40 votes (vote)
: Future
Assigned To: Heikki Toivonen (remove -bugzilla when emailing directly)
: Hixie (not reading bugmail)
Mentors:
http://www.w3.org/TR/xhtml2/
: 186985 (view as bug list)
Depends on: xforms XMLEvents 175107 325208
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 05:31 PDT by Aaron Kaluszka
Modified: 2014-04-25 15:18 PDT (History)
60 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
New XHTML 2.0 tags in res\html.css (12.34 KB, text/css)
2003-01-24 06:02 PST, Dominik
no flags Details
New XHTML 2.0 tags in res\html.css ver 0.2 (12.22 KB, text/css)
2003-01-24 11:57 PST, Dominik
no flags Details

Description Aaron Kaluszka 2002-08-07 05:31:19 PDT
Here we go again...
Comment 1 Heikki Toivonen (remove -bugzilla when emailing directly) 2002-08-07 10:49:58 PDT
This is a long ways off...
Comment 2 Micah Dubinko 2002-08-21 14:55:34 PDT
Adding dependency on XForms
Comment 3 Kai Lahmann (is there, where MNG is) 2002-08-21 15:21:24 PDT
alias for faster searching
Comment 4 Micah Dubinko 2002-08-24 23:02:33 PDT
adding dependency on XML Events
Comment 5 Marcus S 2002-09-05 16:22:15 PDT
Sjoerd Visscher ( sjoerd@w3future.com ) has a XBL based prototype of parts of
the XHTML 2.0 Draft at http://w3future.com/weblog/gems/xhtml2.xml

I don't see any information regarding which license the code is under, but it
would not hurt to contact him and check it out -- I will let you guys know what
happens.
Comment 6 Sjoerd Visscher 2002-09-07 03:31:27 PDT
You can use my XBL files if you want. But I'm pretty sure it's not the way to
implement xhtml 2.0 in Mozilla. It's too slow to convert each node to it's xhtml
1 .1 equivalent with javascript. An XSL conversion is much faster (
http://w3future.com/weblog/gems/xhtml2.xsl ) and it is more flexible than XBL.
Comment 7 John Christopher Jones 2002-09-13 01:27:57 PDT
I'd be extremely happy if Composer only wrote XHTML2.  It seems like it would be
easier than HTML4 on front and back end.
Comment 8 Axel Hecht 2002-09-25 05:07:53 PDT
re #6, I looked at at both the xslt and the xbl implementation.

First of all, let's rule out xslt. It's very unlikely fast, for one. But more
importantly, it changes the displayed document, which makes it impossible
to use js on the original document.

About the performance drag for the xbl version, the attribute foo is probably
really simple and doens't require js, as long as it isn't requiring any
translation of the values.
http://www.xulplanet.com/tutorials/xultu/xblatin.html talks attribute 
inheritance. http://www.mozilla.org/projects/xbl/xbl.html#anonymous-attributes
calls it forwarding, of course ;-)
Adding something like Attribute Value Templates (see
http://www.w3.org/TR/xslt.html#dt-attribute-value-template) to XBL sounds like
a bad idea on a second thought, as more complex algorithms in the evaluation
cause trouble to keep stuff synched in dxhtml2. (Yeah, fancy acronym.)
I don't know if this is required by a xhtml2 implementation, though.

Stuff like the object tag, unifying two html tags is probably a bit more
difficult.

Sjoerd, maybe you could add a relicensed version of the mozilla part of your
stuff to this bug?
Comment 9 Boris Zbarsky [:bz] 2002-12-28 19:11:23 PST
*** Bug 186985 has been marked as a duplicate of this bug. ***
Comment 10 Dominik 2003-01-24 06:02:24 PST
Created attachment 112513 [details]
New XHTML 2.0 tags in res\html.css

I modify the html.css. I add XHTML 2.0 selectors.
Comment 11 Sjoerd Visscher 2003-01-24 06:17:29 PST
From the xhtml 2 spec of the quote element:
"Visual user agents must not add delimiting quotation marks"
http://www.w3.org/TR/xhtml2/mod-text.html#sec_8.13.

So you should remove this part:

quote:before {
  content: open-quote;
}

quote:after {
  content: close-quote;
}
Comment 12 Dominik 2003-01-24 11:57:10 PST
Created attachment 112536 [details]
New XHTML 2.0 tags in res\html.css ver 0.2

I remove content from quote.
Comment 13 Hixie (not reading bugmail) 2003-01-25 03:04:45 PST
That patch uses the wrong namespace for XHTML2.

In any case we must not implement this until XHTML2 is in CR.
Comment 14 Dominik 2003-01-25 03:42:32 PST
Namespace in patch is form 3.1.1. Strictly Conforming Documents -
http://www.w3.org/TR/2002/WD-xhtml2-20021218/xhtml2.html What's wrong with it?
Comment 15 Vedran Miletic 2003-05-08 08:21:23 PDT
http://www.w3.org/TR/2003/WD-xhtml2-20030506/

update
Comment 16 Dominik 2003-05-31 03:08:10 PDT
Mozilla should see the most popular formats like: mpeg, avi, mov (video), mp3,
wav, midi, aiff (sound) not only amimation like gif or mng and images like jpeg,
gif or png. Because in XHTML 2.0 there are not <img>, there are <object>. So
XHTML support not only images (or animations) but also video and sound.
Comment 17 Robin Lionheart 2003-06-01 07:16:12 PDT
adding [meta] and setting component to Tracking
Comment 18 nnooiissee 2004-03-22 21:34:33 PST
Why was bug 162479 removed from the dependancies?
Comment 19 Anne (:annevk) 2004-03-22 23:33:04 PST
Because XFrames has nothing to do with XHTML 2.0. It is a standalone XML
language (some published articles get this wrong).
Comment 20 Tomer Chachamu 2004-12-03 11:28:00 PST
New version:

http://www.w3.org/TR/2004/WD-xhtml2-20040722

Diff: (changed in green, new in yellow)
http://www.w3.org/TR/2004/WD-xhtml2-20040722/xhtml2-diff.html
Comment 21 Jonas Nordlund 2005-08-15 06:29:15 PDT
Almost a year after the previous update, the 7th draft was published in May 2005:
http://www.w3.org/TR/2005/WD-xhtml2-20050527/

Diff-marked version compared to 20040722 here:
http://www.w3.org/TR/2005/WD-xhtml2-20050527/xhtml2-diff.html
Comment 22 Yani (fr) 2007-01-15 12:10:29 PST
8th draft :
http://www.w3.org/TR/2006/WD-xhtml2-20060726/

Diff compared to 2005 05 27 :
http://www.w3.org/TR/2006/WD-xhtml2-20060726/xhtml2-diff.html
Comment 23 Robin Whittleton 2009-07-03 01:10:33 PDT
Guess this is a WONTFIX now then?

http://www.w3.org/News/2009#item119
Comment 24 Samer Ziadeh 2009-07-06 12:01:14 PDT
yeah the w3 will be stopping it. I'm not too fond of this xhtml 5 business though :(
Comment 25 Jacek Piskozub 2009-07-06 12:04:55 PDT
> I'm not too fond of this xhtml 5 business
though :(

I'm sure you mean HTML 5. It seems you really got attached to XHTML ;-)
Comment 27 :Ms2ger 2010-03-13 04:03:12 PST
XHTML2 is not going to happen.

Note You need to log in before you can comment on or make changes to this bug.