Closed Bug 1624858 Opened 4 months ago Closed 4 months ago

WebRender compositor disabled by blocklist when it should not be

Categories

(Core :: Graphics: WebRender, defect, P2)

Desktop
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox75 blocking fixed
firefox76 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

Details

Attachments

(1 file)

Comment on attachment 9135687 [details]
Bug 1624858 - Fix graphics blocklist not recent Windows 10 comparison check.

Beta/Release Uplift Approval Request

  • User impact if declined: They won't get WebRender compositor in late beta and release as we expected.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It was on until recently with early beta. We verified the patch works with a try beta build in both the cases we don't want WebRender compositor, and in the cases we do want WebRender compositor.
  • String changes made/needed:
Attachment #9135687 - Flags: approval-mozilla-beta?
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f498ba0dcc35
Fix graphics blocklist not recent Windows 10 comparison check. r=jrmuizel

Comment on attachment 9135687 [details]
Bug 1624858 - Fix graphics blocklist not recent Windows 10 comparison check.

approved for 75.0b9

Attachment #9135687 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76

This bug is tracked by a release manager but with a small severity so change it to major.
For more information, please visit auto_nag documentation.

Severity: normal → major

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?

Testing Error: Missing Test Coverage. Since then we have been working to improve our deployment test coverage in bugs such as bug 1632259.

Root Cause: ? → Testing Error
You need to log in before you can comment on or make changes to this bug.