Open Bug 1625447 Opened 6 months ago Updated 3 months ago

Open a saved eml file, 'File' > 'save as' > 'File' function not working

Categories

(Thunderbird :: Mail Window Front End, defect)

x86_64
All
defect

Tracking

(Not tracked)

People

(Reporter: anjeyelf, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Save an email using right click 'Save as' , save as type Mail Files (*.eml) to a location outside of Thunderbird eg: desktop
File is saved correctly.
open that .eml file using Thunderbird and email opens in a new window.
Now try to use 'File' > 'Save as' > 'File' because you want to save as a .txt file.

Actual results:

Nothing happens.
Also the 'More' > 'Save as' does not function either.

Expected results:

In the opened .eml file, the 'File' > 'Save as' > 'File' should open a window offering where to save and various options of file types, so allowing to choose to save as eg: txt file.

Copy pasting the source into a text editor program to save as txt file does not produce the ease of readibility. Current workaround is to drag the eml back into Thunderbird 'Local Folders' and use the 'Save as' from within the Thunderbird program.

I can reproduce this using 68.6.0 on Ubuntu 18.04.4 LTS Linux.

Saved the file as test.eml to the Desktop.
Opened it in Thunderbird.
Tried to use Save > File As from the new window and it doesn't bring up the dialog window.

Renamed the saved test.eml file on the Desktop to test.txt.
Clicked on the file and it opened in my text editor application.

Reporter when did this last work as expected?

Flags: needinfo?(anjeyelf)

When you rename a .eml as .txt, the .txt version has all the headers and html, so the file is not as easily readible compared to 'save as' txt. In some emails this can look complicated to an average user. Hence the need to 'save as' a .txt.

Flags: needinfo?(anjeyelf)

(In reply to Anje from comment #2)

When you rename a .eml as .txt, the .txt version has all the headers and html, so the file is not as easily readible compared to 'save as' txt. In some emails this can look complicated to an average user. Hence the need to 'save as' a .txt.

Yes, I ran a couple of tests and can see the difference.

I can reproduce using versions 52.9.1 and 60.9.1 in my test user account with fresh profiles for each version.

Edit: Also tested version 45.8.0 and can reproduce the issue.

Did this ever work?

Flags: needinfo?(anjeyelf)
OS: Unspecified → All
Hardware: Unspecified → x86_64

Must admit I'm not sure if this ever worked as I usually save as eml. It was drawn to my attention when a user posted a support question, so I tested to see what was going on and confirmed there was a problem. It seems to be one of those that slipped through the net, but I can understand the need to save as a txt file. It works if you do it directly via Thunderbird on an email stored in any folder, but not if you save as eml and then open the eml using Thunderbird.
I tested using Windows 10 and Tb version 68.6.0 win32.
Support question:
https://support.mozilla.org/en-US/questions/1282838

Flags: needinfo?(anjeyelf)

I am the one who posted a request for help in the Thunderbird forum (Link: https://support.mozilla.org/en-US/questions/1282838 ). - note: I changed my profile name from mark2012 to mark2090.

To ensure this issue is clear as to what the problem is,
: Email file is external from the Thunderbird program, whether it was saved from Thunderbird to the desktop or from another email program (ie: Windows Mail APP).
: Opening the external EML file opens in Thunderbird, whether Thunderbird is the default program or opened in Thunderbird using windows "Open With" command.
: When opened in Thunderbird, any attempts to "Save as" in any of the formats offered by Thunderbird (EML, HTML, TXT, or .) fail, the save-as dialogue window does not appear.
: Same issue when trying to save-as "Template".

What I was trying to do is re-save the external EML file as an HTML file. The only way I could do that using Thunderbird was to open Thunderbird first, and then drag the external EML file into any one of the folders that exist in Thunderbird. Then the Save-as dialogue window works.

I see above that others have confirmed this issue exists in Thunderbird.

Status: UNCONFIRMED → NEW
Component: Untriaged → Mail Window Front End
Ever confirmed: true
Version: 68 → 60

Uncaught
Exception

columnNumber: 0

data: null

filename: "chrome://messenger/content/mailCommands.js"

lineNumber: 406

location: XPCWrappedNative_NoHelper { QueryInterface: QueryInterface(), filename: Getter, name: Getter, … }

message: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgMessageService.messageURIToMsgHdr]"

name: "NS_ERROR_FAILURE"

result: 2147500037

stack: "SaveAsFile@chrome://messenger/content/mailCommands.js:406:55\nMsgSaveAsFile@chrome://messenger/content/mailWindowOverlay.js:2219:13\ndoCommand@chrome://messenger/content/messageWindow.js:1342:9\ngoDoCommand@chrome://global/content/globalOverlay.js:101:18\noncommand@chrome://messenger/content/messageWindow.xhtml:1:12\n"

<prototype>: ExceptionPrototype { toString: toString(), name: Getter, message: Getter, … }
mailCommands.js:406
SaveAsFile chrome://messenger/content/mailCommands.js:406
MsgSaveAsFile chrome://messenger/content/mailWindowOverlay.js:2219
doCommand chrome://messenger/content/messageWindow.js:1342
goDoCommand chrome://global/content/globalOverlay.js:101
oncommand chrome://messenger/content/messageWindow.xhtml:1
An error occurred executing the cmd_saveAsFile command: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgMessageService.messageURIToMsgHdr]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/mailCommands.js :: SaveAsFile :: line 406" data: no] globalOverlay.js:104
goDoCommand chrome://global/content/globalOverlay.js:104
oncommand chrome://messenger/content/messageWindow.xhtml:1

You need to log in before you can comment on or make changes to this bug.