Closed Bug 1625806 Opened 4 months ago Closed 2 months ago

Decision task bustage on try-comm-central, references to expired job

Categories

(Thunderbird :: Build Config, defect)

defect

Tracking

(thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 --- fixed

People

(Reporter: rjl, Assigned: rjl)

Details

Attachments

(6 files)

The decision task on try-comm-central errors out:

'task.dependencies' references tasks that expires before 'task.deadline' this is not allowed, see tasks:
 * OIKXEGQ8SX2rS5mcmh5pYg,
All taskIds in 'task.dependencies' **must** have
'task.expires' greater than the 'deadline' for this task.

The offending task is a libotr build. On try, they expire after 28 days so you can no longer use them as a dependency.
For regular toolchain jobs the expiration is 12 months (even on try).

Not sure why I set try jobs to 28 days in the first place.
Toolchain jobs on try expire after a year, so that's probably
a good place to start.

A better fix will be to somehow check the expiration of the task
in question.
Attachment #9136651 - Flags: review?(geoff)
Assignee: nobody → rob
Status: NEW → ASSIGNED
Force a rebuild of libotr to deal with the expired task.
Attachment #9136653 - Flags: review?(geoff)

Marking leave-open because even with the above "fix" if we don't update libotr code within a year we will have the same issue on all repos, not just try-comm-central.
Chances are the code will get touch sometime in that year, but it may not.
The other thing is I have been meaning audit the index lookup on the libotr build jobs to make sure it really works as intended. When something else causes a libotr rebuild, such as a toolchain dependency changing, does the index point to the new build like it should?

Keywords: leave-open
Attachment #9136651 - Flags: review?(geoff) → review+
Attachment #9136653 - Flags: review?(geoff) → review+
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/b90745e722fc
Expire all libotr build tasks after 1 year. r=darktrojan
https://hg.mozilla.org/comm-central/rev/529118ef44ee
Removed unused variable from build-libotr.sh. r=darktrojan

Getting this out of my active queue for now.

Assignee: rob → nobody
Status: ASSIGNED → NEW

This is back causing trouble on try-comm-central. Will push a hot-fix as soon as I test it and will come up with better longterm fix ASAP.

Assignee: nobody → rob

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → S3

The severity of these bugs was changed, mistakenly, from normal to S3.

Because these bugs have a priority of --, indicating that they have not been previously triaged, these bugs should be changed to Severity of --.

Severity: S3 → --

Toolchain builds have things in a slightly different arrangement. GECKO_PATH
is at /builds/worker/workspace/build/src, so removing build at line 17 will
delete the checkout we need for the libotr sources.
At the same time, this script will also run on the thunderbird-mingw docker
image which uses the build image layout, and the build directory will need
to be created.
In either case, workspace can be cached between Taskcluster runs under some
circumstances so clearing out the directories that this script uses is still
warranted.

The thirdparty build kind has problems with indexing that never really worked
out. By using the existing toolchain kind we can rely on that indexing that has
seen a lot more use and be more confident that it works right.

Depends on D78205

Attachment #9154058 - Attachment description: Bug 1625806 - Remove unused thirdparty transform code. rf?darktrojan → Bug 1625806 - Remove unused thirdparty transform code. r?darktrojan
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/0dee0f41284b
Modify build-libotr.sh to work as a toolchain build script. r=darktrojan
https://hg.mozilla.org/comm-central/rev/84e760152741
Build libotr as a toolchain dependency. r=darktrojan
https://hg.mozilla.org/comm-central/rev/8ef9d3a2c1ec
Use libotr toolchain task instead of thirdparty task as build dependency. r=darktrojan
https://hg.mozilla.org/comm-central/rev/98c0fbe4a5e8
Remove unused thirdparty transform code. r=darktrojan
Status: NEW → RESOLVED
Closed: 2 months ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 79.0

Comment on attachment 9154049 [details]
Bug 1625806 - Modify build-libotr.sh to work as a toolchain build script. r=darktrojan

[Triage Comment]
Build infra refactoring. This bug goes with bug 1639949 which is required for bug 1634209.

Attachment #9154049 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.