Closed Bug 1626381 Opened 4 months ago Closed 4 months ago

Back button and categories have no a11y label

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 + fixed
firefox77 + fixed

People

(Reporter: Jamie, Assigned: mstriemer)

References

(Regression)

Details

(Keywords: access, regression, Whiteboard: [access-p1])

Attachments

(1 file)

The back button in the new HTML side bar has no label for accessibility. I assume there's only an icon.

Consider using the title attribute so that sighted users who might not understand the icon get a tooltip telling them what it does. If you really don't want a visual tooltip or label, use aria-label.

The regular label gets hidden in the responsive mode where it is indeed just an icon. These buttons should probably have a title attribute for that case.

Assignee: nobody → mstriemer
Priority: -- → P1
Regressed by: 1525175
Summary: Back button has no a11y label → Back button and categories have no a11y label
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bca3d696a1a7
Include a title on about:addons categories r=rpl,fluent-reviewers,flod
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

I'm guessing there's not much we can do for 76 at this point given where we are in the cycle and the amount of time left for localizers to take care of any new strings. Feel free to nominate for uplift if the l10n team thinks it's doable, though.

Flod, this patch has a migration and all the strings are being migrated from the old ones. Is this safe to uplift to beta? Would the strings get migrated?

Flags: needinfo?(francesco.lodolo)

Yes, we could uplift, since we already migrated existing translations.

Flags: needinfo?(francesco.lodolo)

Comment on attachment 9138055 [details]
Bug 1626381 - Include a title on about:addons categories r?rpl

Beta/Release Uplift Approval Request

  • User impact if declined: Screen reader users won't hear the back button's description when it is focused. On narrow screen sizes the sidebar buttons won't have any title text on hover (the primary text is hidden) or have a screen reader label read out.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple patch that adds additional more l10n calls, l10n strings and a migration.
  • String changes made/needed: Yes, migration is available
Attachment #9138055 - Flags: approval-mozilla-beta?

Comment on attachment 9138055 [details]
Bug 1626381 - Include a title on about:addons categories r?rpl

about:addons improvement for screen reader users. Approved for 76.0b6.

Attachment #9138055 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.