Closed Bug 1626482 Opened 4 months ago Closed 3 months ago

Intermittent toolkit/components/extensions/test/mochitest/test_ext_identity.html | onSendHeaders called for redirect url: <random text>

Categories

(WebExtensions :: General, defect, P5)

defect

Tracking

(firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rpl)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered])

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=295681433&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/aQfAQ_bbT3W4vzNBb26-9g/runs/0/artifacts/public/logs/live_backing.log


[task 2020-04-01T00:46:20.961Z] 00:46:20 INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_identity.html | expected redirect uri matches hash - Expected: https://35b64b676900f491c00e7f618d43f7040e88422e.example.com/identity_cb, Actual: https://35b64b676900f491c00e7f618d43f7040e88422e.example.com/identity_cb
[task 2020-04-01T00:46:20.961Z] 00:46:20 INFO - Buffered messages finished
[task 2020-04-01T00:46:20.961Z] 00:46:20 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_identity.html | onSendHeaders called for redirect url: {"requestId":"260","url":"https://35b64b676900f491c00e7f618d43f7040e88422e.example.com/identity_cb?access_token=here+ya+go","originUrl":"https://example.com/tests/toolkit/components/extensions/test/mochitest/oauth.html?redirect_uri=https%3A%2F%2F35b64b676900f491c00e7f618d43f7040e88422e.example.com%2Fidentity_cb","method":"GET","type":"main_frame","timeStamp":1585701980524,"frameId":0,"parentFrameId":-1,"thirdParty":false,"proxyInfo":null,"ip":null,"frameAncestors":[],"urlClassification":{"firstParty":[],"thirdParty":[]},"requestSize":0,"responseSize":0,"tabId":31,"incognito":false}
[task 2020-04-01T00:46:20.961Z] 00:46:20 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:299:16
[task 2020-04-01T00:46:20.961Z] 00:46:20 INFO - testHandler@SimpleTest/ExtensionTestUtils.js:72:18
[task 2020-04-01T00:46:20.961Z] 00:46:20 INFO - testResult@SimpleTest/ExtensionTestUtils.js:82:18
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - AsyncExtensionTestUtils.loadExtension@SimpleTest/ExtensionTestUtils.js:113:33
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - test_interaction@toolkit/components/extensions/test/mochitest/test_ext_identity.html:315:38
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - nextTick/<@SimpleTest/SimpleTest.js:2090:34
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - async
nextTick@SimpleTest/SimpleTest.js:2115:11
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - setTimeout handler*SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:788:41
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - add_task@SimpleTest/SimpleTest.js:2045:17
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - @toolkit/components/extensions/test/mochitest/test_ext_identity.html:15:9
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_identity.html | correct redirect url https://35b64b676900f491c00e7f618d43f7040e88422e.example.com/identity_cb?access_token=here+ya+go
[task 2020-04-01T00:46:20.962Z] 00:46:20 INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_identity.html | Handled auto redirection - Expected: here ya go, Actual: here ya go
[task 2020-04-01T00:46:21.036Z] 00:46:21 INFO - add_task | Leaving test test_interaction
[task 2020-04-01T00:46:21.036Z] 00:46:21 INFO - add_task | Entering test test_auto303Redirect
[task 2020-04-01T00:46:21.036Z] 00:46:21 INFO - Extension loaded

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

Andrea, is it possible that changes in Bug 1639154 made this bug more frequent? Treeherder link with retriggers.

Flags: needinfo?(amarchesini)
Regressed by: 1639154
Whiteboard: [retriggered]

Even if Bug 1639154 makes this bug more frequent, the bug is in the test or in the underlying code. Bug 1639154 is about partitioning the network cache, and this doesn't change the number of network redirects.

Luca, do you mind to take a look?

Flags: needinfo?(amarchesini) → needinfo?(lgreco)

(In reply to Andrea Marchesini [:baku] from comment #7)

Even if Bug 1639154 makes this bug more frequent, the bug is in the test or in the underlying code. Bug 1639154 is about partitioning the network cache, and this doesn't change the number of network redirects.

Luca, do you mind to take a look?

sure, I'll take a look asap (possibly today)

Assignee: nobody → lgreco

I have been able to reproduce it consistently enough on macos but I need to look a bit more deeply to apply a proper fix (on the test case or maybe even on the identity API implementation side).

I discussed about this briefly with Shane and agreed to start by dealing with the intermittency first by setting the privacy.partition.network_state pref to false inside the test, which does seems to be preventing the recent higher intermittency:

I'm going to file a separate follow up for a more complete fix.

Flags: needinfo?(lgreco)
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/e230153536a6
Set privacy.partition.network_state to false in test_ext_identity to avoid intermittent failures. r=mixedpuppy
Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.