Closed Bug 1639154 Opened 3 months ago Closed 3 months ago

Isolate network cache per first-party when privacy.partition.network_state is set to true

Categories

(Core :: Privacy: Anti-Tracking, task)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: baku, Assigned: baku)

References

(Blocks 1 open bug, Regressed 2 open bugs)

Details

Attachments

(2 files)

No description provided.
Assignee: nobody → amarchesini
Status: NEW → ASSIGNED
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66abd66fc467
Isolate network cache per first-party when privacy.partition.network_state is set to true - part 1 - implementation, r=mayhemer,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/7e53b5398797
Isolate network cache per first-party when privacy.partition.network_state is set to true - part 2 - tests, r=mayhemer

Excuse my ignorance, but with these patches, such as this one and Bug 1639247, do they isolate the "same" as FPI (privacy.firstparty.isolate) or is it different? (note: FPI & dFPI in Bug 1631676). In other words, when flipped on, will they causes any conflicts or always be the most restrictive if there is a difference in approach? TIA

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Regressions: 1626482
Regressions: 1641270
Duplicate of this bug: 1594004
Duplicate of this bug: 1596271
Regressions: 1650609
You need to log in before you can comment on or make changes to this bug.