Closed Bug 1626892 Opened 4 months ago Closed 4 months ago

The elements of a login item are cropped if the browser window is narrowed

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- verified

People

(Reporter: srosu, Assigned: jaws)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Resize.gif

[Affected versions]:

  • Nightly 76.0a1 (Build ID: 20200401212659)

[Affected Platforms]:

  • Windows 10 x64
  • Mac 10.14.6
  • Ubuntu 18.04 x64

[Prerequisites]:

  • Have a Firefox profile with at least one saved login.

[Steps to reproduce]:

  1. Open the Firefox browser with the profile from prerequisites.
  2. Navigate to the “about:logins” page.
  3. Select a saved login.
  4. Resize the browser less than 50% of its width.
  5. Scroll the page using the horizontal scroll bar and observe the elements from the Login view.

[Expected result]:

  • The elements from the Login view are correctly displayed.

[Actual result]:

  • The elements from the Login view are cropped.

[Notes]:

  • This issue seems to be caused by the Bug 1625967.
  • Attached a screen recording with the issue.
No longer regressed by: 1625967
Component: about:logins → Graphics
Product: Firefox → Core

Hi Jessie, can you please help me triage this or get this on someone's radar? It looks like we're not invalidating correctly when the user horizontally scrolls in this case.

Flags: needinfo?(jbonisteel)

Kats - can you take a look? Not sure if this would be APZ, technically.

Flags: needinfo?(jbonisteel) → needinfo?(kats)

There are actually three different scrollable areas on this page: one covering the whole page, and one covering the pane on the left side, and one covering the pane on the right side. So if you scroll right on the whole page, and then scroll right on the right pane the rest of the content can be revealed. So this seems like an issue with the page itself.

Priority: -- → P3
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Component: Graphics → about:logins
Flags: needinfo?(kats)
Product: Core → Firefox

The product::component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --
Priority: -- → P3
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33fe9b3d615f
Set a minimum width on the flexible column to make sure that it will always match the header in width in the event the header is larger than the grid. r=ntim
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

Reproduced the initial issue using an old Nightly build 76.0a1 (build id: 20200401095134) using Windows 10.
Verified - Fixed in latest Nightly build 76.0a1 (build id: 20200405212522) using Windows 10 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.