Closed Bug 1626967 Opened 3 months ago Closed 3 months ago

Cranelift: preparatory refactorings for new-isel integration

Categories

(Core :: Javascript: WebAssembly, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: bbouvier, Assigned: bbouvier)

References

Details

Attachments

(4 files)

No description provided.
Summary: Cranelift: reparatory refactorings for new-isel integration → Cranelift: preparatory refactorings for new-isel integration

This goes hand in hand with
https://github.com/bytecodealliance/wasmtime/pull/1460, which will need to be
merged first.

This removes most of the Spidermonkey-specific machinery to collect
relocations. The only remaining place is for stack-maps, which will be handled
later.

This favors Rust, but there's no way to generate different names in the
bindings, as far as I know.

This avoids one platform-specific number (3 for x86_64, 4 for arm64).

Priority: -- → P3
Attachment #9137780 - Attachment description: Bug 1626967: Provide Cranelift the size of wasm::Frame from a StaticEnvironment value; r?hunt → Bug 1626967: Provide Cranelift the size of wasm::Frame from a StaticEnvironment value; r?rhunt
Pushed by bbouvier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29aaf3ff21ea
bump Cranelift to 6a68130d5b0296379fae0b8de5fbb8a1499b67a5; r=jseward
https://hg.mozilla.org/integration/autoland/rev/f48ad40e60af
Use the regular Cranelift sinks to keep track of relocations; r=rhunt
https://hg.mozilla.org/integration/autoland/rev/837dab8ce31c
Use snake_case in shared Cranelift data structures; r=rhunt
https://hg.mozilla.org/integration/autoland/rev/985eea91c36c
Provide Cranelift the size of wasm::Frame from a StaticEnvironment value; r=rhunt
Regressions: 1628050

Backed out for breaking Raptor tests godot-c and wm-c:

https://hg.mozilla.org/integration/autoland/rev/881935e4aa214dfb5b601b98ea01ded4299ead7d

Due to a misconfiguration, they run as tier-1 but only on mozilla-central: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&selectedJob=296745910&searchStr=rap&revision=6c6c67870c37b2e414f898e390ed5247d8e1e94a
They also have to run on autoland or as tier-2.

Status: RESOLVED → REOPENED
Flags: needinfo?(bbouvier)
Resolution: FIXED → ---
Target Milestone: mozilla77 → ---
No longer regressions: 1628050
Attachment #9138783 - Attachment description: Bug 1626967: bump Cranelift to 6a68130d5b0296379fae0b8de5fbb8a1499b67a5; r?jseward → Bug 1626967: bump Cranelift to 6a68130d5b0296379fae0b8de5fbb8a1499b67a5; r=jseward
Attachment #9137778 - Attachment description: Bug 1626967: Use the regular Cranelift sinks to keep track of relocations; r?rhunt → Bug 1626967: Use the regular Cranelift sinks to keep track of relocations; r=rhunt
Attachment #9137779 - Attachment description: Bug 1626967: Use snake_case in shared Cranelift data structures; r?rhunt → Bug 1626967: Use snake_case in shared Cranelift data structures; r=rhunt
Attachment #9137780 - Attachment description: Bug 1626967: Provide Cranelift the size of wasm::Frame from a StaticEnvironment value; r?rhunt → Bug 1626967: Provide Cranelift the size of wasm::Frame from a StaticEnvironment value; r=rhunt

Manually rebased and queued for re-landing (it wasn't this bug which caused the error which lead to this backout).

Flags: needinfo?(bbouvier)
Pushed by bbouvier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef939dda0a03
bump Cranelift to 6a68130d5b0296379fae0b8de5fbb8a1499b67a5; r=jseward
https://hg.mozilla.org/integration/autoland/rev/fb80ccae7376
Use the regular Cranelift sinks to keep track of relocations; r=rhunt
https://hg.mozilla.org/integration/autoland/rev/b44cac1aa5f1
Use snake_case in shared Cranelift data structures; r=rhunt
https://hg.mozilla.org/integration/autoland/rev/09c016706d3f
Provide Cranelift the size of wasm::Frame from a StaticEnvironment value; r=rhunt

(Had to rebase manually again, duh.)

You need to log in before you can comment on or make changes to this bug.