Closed Bug 1627378 Opened 8 months ago Closed 7 months ago

Address bar doesn't remain highlighted when clicked immediately following opening new window

Categories

(Firefox :: Address Bar, defect, P2)

75 Branch
x86_64
macOS
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 77
Iteration:
77.1 - Apr 6 - Apr 19
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- verified
firefox77 --- verified

People

(Reporter: bugzilla, Assigned: harry)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Steps to reproduce:

1: Start Firefox or open a new window
2: Immediately click on the address bar

Actual results:

Actual results:

URL in address bar gets briefly highlighted before reverting to non-highlighted state with the cursor at the beginning

Expected results:

Expected results:

URL in address bar is and remains highlighted

OS: Unspecified → macOS
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar
Version: 74 Branch → 75 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

(In reply to Alice0775 White from comment #2)

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fb816f83f64cd253d7ece0ae809f6be8d5b88aba&tochange=54527f838bf5d344d53f5313391e3fe959050c2a

This is weird, bug 1528593 just renamed properties and shouldn't have changed behavior. Maybe there's some code using value that should have been updated to untrimmedValue? Harry, could you please take a look?

Flags: needinfo?(htwyford)
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 77.1 - Apr 6 - Apr 19
Points: --- → 2
Flags: needinfo?(htwyford)

This bug is unrelated to the address bar update. It affects the old address bar as well.

No longer blocks: urlbar-update-1
Attachment #9140146 - Attachment description: Bug 1627378 - Rename gURLBar.value getters missed in bug 1528593. r?dao → Bug 1627378 - Rename gURLBar.value getter missed in bug 1528593. r?dao
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7450bc82c694
Rename gURLBar.value getter missed in bug 1528593. r=dao
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

Comment on attachment 9140146 [details]
Bug 1627378 - Rename gURLBar.value getter missed in bug 1528593. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: Annoying UI bug where the URL could become un-highlighted.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line change to Urlbar JS. The scope of possible regressions is very small and nothing has been reported so far.
  • String changes made/needed:
Attachment #9140146 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9140146 [details]
Bug 1627378 - Rename gURLBar.value getter missed in bug 1528593. r?dao

Fixes an annoying UI glitch. Approved for 76.0b5.

Attachment #9140146 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

We could not reproduce this issue on any of our machines.
Alice, could you please help us confirm this fix?

Thank you!

Flags: needinfo?(alice0775)

I can reproduce the issue on Nightly77.0a1(20200414094457) and Firefox76.0b4 Windows10.
And I verified that the problem is no longer reproduce on Nightly77.0a1(20200416094846) and Firefox76.0b5.

Flags: needinfo?(alice0775)
You need to log in before you can comment on or make changes to this bug.