There are no system sounds in Mozilla at all.

VERIFIED DUPLICATE of bug 83056

Status

()

defect
VERIFIED DUPLICATE of bug 83056
17 years ago
13 years ago

People

(Reporter: sburner, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

Mozilla doesn't use system sounds. There are no sounds in menu, when poping up
dialogs, etc.

Reproducible: Always
Steps to Reproduce:
1. Select any full sound scheme in your Windows control panel
2. Start Mozilla
3. Try clicking the menu or making any message dialog to pop up

Actual Results:  No sounds played

Expected Results:  Sounds had to be played (as in all other Windows' apps)

I know, that Mozilla is a cross-platform app, but you can quite use #ifdef
instructions or something like this.
Reporter

Updated

17 years ago
Component: XP Apps → Browser-General
looks like bug 83056 covers much of this (mac: bug 74628) ->xptk
Assignee: sgehani → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
Depends on: 83056
QA Contact: paw → jrgm

Comment 2

17 years ago
Yes.  My patch for bug 83056, attachment 53481 [details] [diff] [review] (woefully out of date, I'm sure),
establishes the framework for playing system sounds.  There was talk from Hyatt
in that bug of adding theme support for sounds as well.

Comment 3

17 years ago
mark dupe then...

*** This bug has been marked as a duplicate of 83056 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED

Updated

13 years ago
No longer depends on: 83056
You need to log in before you can comment on or make changes to this bug.