Popups, windows do not play the appropriate appearance theme sound

RESOLVED EXPIRED

Status

defect
--
minor
RESOLVED EXPIRED
18 years ago
9 years ago

People

(Reporter: adamlock, Assigned: jag+mozilla)

Tracking

(Blocks 1 bug)

Trunk
PowerPC
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla on the Macintosh does not play appearance theme sounds for events such 
as window scolling, popup menu opening and item selection etc.

Steps to reproduce:

1. Open the Appearance control panel and enable sounds for menus, windows, 
controls etc.
2. Run Mozilla
3. Compare sounds made for popup/bookmark menu opening/closing, tooltips, menu 
item selection, button clicks, scrolling etc. against IE or other applications. 
Mozilla is practically silent.

Mozilla should use the appearance manager to send out the right sounds for these 
user actions.
(Reporter)

Comment 1

18 years ago
*** Bug 74629 has been marked as a duplicate of this bug. ***
QA Contact: sairuh → claudius
patty/claudius, could one of you take this as qa? thx!

Comment 3

18 years ago
Changing platform
Hardware: PC → Macintosh

Comment 4

18 years ago
Not only the "theme sounds" but all the theme settings: Arrow and Smart
Scrolling. See next attachment.
To reproduce: On any link make: Open link in New Window

Comment 6

18 years ago
marking p4 and future
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 7

18 years ago
CC'ing Chris Saari. This sounds like something Apple would be interested in
seeing fixed sooner than future.

Updated

18 years ago
Depends on: 67775

Comment 8

18 years ago
-> default assignee
Assignee: pchen → trudelle
Status: ASSIGNED → NEW
QA Contact: claudius → sairuh
Target Milestone: Future → ---

Comment 9

17 years ago
->future
Target Milestone: --- → Future

Comment 10

16 years ago
Mozilla CFM/Classic build is dead.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
actually, i think an OS X system pref exists for sound behavior of UI elements
(under the Sound system pref), so this might be valid for mach-o. reopening.
Status: RESOLVED → REOPENED
OS: Mac System 9.x → MacOS X
Resolution: WONTFIX → ---

Comment 12

16 years ago
Yes, there is a "Play user interface sound effects" checkbox in OSX. However, I
can confirm that Mozilla does indeed play the appropriate sounds: none, just
like all OSX apps.
Severity: normal → minor

Comment 13

16 years ago
Hi - I have no particular interest in this bug but got email
about it.  Yet I am NOT on the CC list and there does
not seem to be any other option to take myself off.
Would someone please explain to me why I got on this bug list
and how to get off again?  Also, how does one get a master
list of all bugs I'm on??

Comment 14

16 years ago
Tom, you voted for this bug. http://bugzilla.mozilla.org/votes.cgi?action=show_user

Comment 15

16 years ago
Thanks, that's very weird.  Since I don't use theme sounds,
I would not have voted for it.  Seems unlikely I would have
done so accidently.  Maybe it's a bug in bugzilla that changed my list of votes?
Anyway, I have removed my vote - the only one!
Product: Core → Mozilla Application Suite
Assignee: trudelle → jag
Status: REOPENED → NEW
Priority: P4 → --
QA Contact: bugzilla
Target Milestone: Future → ---

Updated

11 years ago
Blocks: 461963

Comment 16

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 17

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 21

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 22

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.