Closed Bug 1627713 Opened 4 years ago Closed 4 years ago

Firefox AppStream metainfo file is broken

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED INVALID

People

(Reporter: mail, Unassigned)

Details

Attachments

(2 files)

Attached image firefox_details1.png

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

If you try to install Firefox on Linux using GNOME Software, KDE Discover or any other modern GUI software centers, you will experience issues. In most cases, Firefox is not even available in the search results (even if you already have it installed) or its details page is displayed incorrectly (see the attached screenshot for official Flatpak version). There is something wrong in the AppStream appdata/metainfo file. The issues seem to happen on Ubuntu, Fedora and other GNU/Linux distributions. It started happening about year ago and happens to this day (Firefox 75). There is no such issue with any other application, except Firefox.

Actual results:

When searching for Firefox in GNOME Software, either no results were found or a broken details page was displayed.

Expected results:

When searching for Firefox in GNOME Software, it is found without any issue and clicking the result opens a correct details page.

Attached image firefox_details2.png

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Hmm, I am not sure if this is a duplicate. The Flathub Firefox issue seems to be another issue, sorry for the confusion. Anyway, it seems that the AppStream file or other Firefox metadata (that the gnome-software AppStream parser reads) on both Fedora and Ubuntu have something wrong in them that is causing Firefox metadata to not be parsed at all. This does not seem to happen for Flatpaks for some reason, only for rpms/debs and other system packages.

I have once again checked the issues in Ubuntu and Fedora and it seems that the issue in Ubuntu is definitely a downstream one, caused by a appstream-generator bug, and the Fedora issue is most likely a downstream one as well. So, feel free to close this ticket as a #1627660 duplicate.

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is P3 (Backlog,) indicating it has been triaged, the bug's Severity is being updated to S3 (normal.)

Severity: normal → S3

The Flathub version of Firefox has still problems with its AppStream metadata file. It has missing screenshots and other issues, I have created a new bz for it: https://bugzilla.mozilla.org/show_bug.cgi?id=1639848

The regular distribution Firefox seems to be fine now in both Fedora and Ubuntu. The issues I mentioned turned out to be downstream ones and were fixed. I am closing this bz, please, focus on bz#1639848 instead. Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: