Closed Bug 1628241 Opened 1 year ago Closed 9 months ago

When traversing to a table with VoiceOver, VoiceOver immediately lands on the first cell.

Categories

(Core :: Disability Access APIs, defect, P3)

77 Branch
All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- fixed

People

(Reporter: MarcoZ, Unassigned)

References

()

Details

(Whiteboard: [Mac2020_1])

STR:

  1. Go to https://a11ysupport.io/tech/aria/aria-current_attribute.
  2. Go to the first table with VoiceOver. The quickest way is to press CTRL+Option+Cmd+T.
    • Expected: VoiceOver says Table, followed by the caption, and the column and row count.
    • Actual: VoiceOver speaks that, but also that focus is on the first cell.

Doing the same in Safari gives an extra stop for the table element itself before CTRL+Option+RightArrow takes the user to the first actual cell in the table.

Eitan, I wasn't sure about the priority for this one, if it should be in 27 or later. It is not a regression, it has behaved like this since I started testing. Feel free to adjust.

Flags: needinfo?(eitan)

I can't reproduce this. It speaks the table info. When I press VO+right it jumps to the econd column header. I wonder if that is the same bug?

Flags: needinfo?(eitan)

Yep. The announcement seems to vary a bit, sometimes on my machine it speaks both the table info followed by the first column, but the next VO+RightArrow definitely always takes me to the second column.

Severity: normal → S3

Marco since bug 1628236 was fixed, do you still see this issue? I don't.

Flags: needinfo?(mzehe)

Confirmed that this is fixed by bug 1628236.

Status: NEW → RESOLVED
Closed: 9 months ago
Depends on: 1628236
Flags: needinfo?(mzehe)
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.