Closed Bug 1628286 Opened 8 months ago Closed 8 months ago

Add preference in settings to disable new address bar design (megabar)

Categories

(Firefox :: Address Bar, enhancement)

76 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1585912

People

(Reporter: jeanpaul, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

I have to play with temporay settings in about:config or copy paste random css in userChrome.css to be able to disable the new oversized url bar.

Actual results:

Currently there are various prefs in about:config to set to false to revert the Megabar expansion / automatic dropdown. (For example, browser.urlbar.update and browser.urlbar.openViewOnFocus). Those will probably be removed later.

Expected results:

There should be a userfriendly setting in about:preferences to be able to toggle off this annoyance easily.

Component: Untriaged → Preferences
Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Component: Preferences → Address Bar
Resolution: --- → DUPLICATE
Duplicate of bug: 1627858

It is not a duplicate of 1627858. This is not about a Top Site option.

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

We don't plan to allow disabling the new design, if there are specific things breaking your workflow, please file those as bugs.
We plan to add a visible pref to disable top sites auto-opening.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → WONTFIX

(In reply to jp from comment #2)

It is not a duplicate of 1627858. This is not about a Top Site option.

Summary: Move Megabar prefs from about:config to proper about:preferences settings → Add preference in settings to disable new address bar design (megabar)
Duplicate of this bug: 1628251
You need to log in before you can comment on or make changes to this bug.