Closed Bug 1585912 Opened 9 months ago Closed 9 months ago

Preference to control MegaBar have to be added to GUI Options/about:preferences

Categories

(Firefox :: Address Bar, defect)

71 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED WONTFIX
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- disabled
firefox71 --- wontfix

People

(Reporter: Virtual, Unassigned)

References

(Blocks 1 open bug)

Details

(4 keywords)

STR:

  1. Start latest Mozilla Firefox Nightly 71.0a1 (2019-10-02)
  2. Make sure that "browser.urlbar.megabar" preference is set to "true" in about:config/"Advanced Preferences" (should be enabled by default in latest Mozilla Firefox Nightly)
  3. Have all animations disabled by setting these preferences to "false":
  • browser.download.animateNotifications
  • browser.stopReloadAnimation.enabled
  • toolkit.cosmeticAnimations.enabled
  1. See that some MegaBar is now enabled by default
  2. Try to disable it in GUI Options/about:preferences, because this feature it's tiresome and exhausting on my morbid and unhealthy eyes per flashing/flickering/blinking on white, and see that there is no any preference to control this feature in GUI Options/about:preferences.

Please provide option to control this new feature in GUI Options/about:preferences, as for now only "browser.urlbar.megabar" preference hidden in about:config/"Advanced Preferences" control it and hiding preferences in about:config/"Advanced Preferences" doesn't seem overall like good idea, as how user will know about this that some hidden preference control this, especially for some new feature, which affecting users with disability and diseases.

It could be located in Options ( about:preferences ) for example in "Search" tab ( about:preferences#search ) or in "General" tab ( about:preferences#general) under "Browsing" section.

Has Regression Range: --- → yes
Has STR: --- → yes

I don't think we'll expose a preference, it's a new design that will likely become the default, it's currently possible to disable it just because there are a few bugs remaining.

We are respecting prefers-reduced-motion from bug 1584273, that avoids the animations, but will still expand. It should be set by the OS accessibility features, IIRC.
Maybe we could respect toolkit.cosmeticAnimations.enabled, but again it would just avoid the animations, but still expand/contract. would that help?
Animations are probably still in need of some tweaks.

Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(Virtual)

So, for example on Mac there is a Reduce Motion pref under accessibility.

(In reply to Marco Bonardo [::mak] from comment #1)

I don't think we'll expose a preference, it's a new design that will likely become the default, it's currently possible to disable it just because there are a few bugs remaining.

Ability to control (disable and enable) software features (especially new ones) are crucial and vital. Forbidding and disallowing it is for me like kinda disrespecting for users, like kinda saying "you have to and you must use software like we want, not in other way and not like you want". In my opinion there is no single logical reason for Mozilla developers to hide this preference in Firefox in about:config/"Advanced Preferences" and not add it to GUI Options/about:preferences, while other preferences for more minor futures are already exists there. What's more you even want to complete and wholly remove preference to control this in about:config/"Advanced Preferences". Looks like it's over my head... but I'm still hoping that Mozilla developers will change theirs decision about it, so it won't be only one person decision and it will be discussed wide and broad.

(In reply to Marco Bonardo [::mak] from comment #1)

We are respecting prefers-reduced-motion from bug 1584273, that avoids the animations, but will still expand. It should be set by the OS accessibility features, IIRC.
Maybe we could respect toolkit.cosmeticAnimations.enabled, but again it would just avoid the animations, but still expand/contract. would that help?
Animations are probably still in need of some tweaks.

Animations are one thing, which I disabled for same reason, why I also disabled MegaBar feature, but I'm mainly talking about flashing/flickering/blinking on white some wide and large area in Address Bar, which is tiresome and exhausting on my morbid and unhealthy eyes and is affecting users with disability and diseases.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(Virtual)

(In reply to Virtual_ManPL [:Virtual] 🇵🇱 - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #3)

Ability to control (disable and enable) software features (especially new ones) are crucial and vital.

This is not exactly a feature, it's the design of the product, like how you present yourself to other people. If we think it doesn't serve well our users, it will be changed. Providing preferences for everything is a no-exit way, everyone has different preferences, and that's normal. On design it's also worse, because it's a lot more subjective. Imo it's not disrespectful towards users, it's just how software development works. Think if Microsoft should allow to switch Windows graphics from the ones in Windows 10 to the one in Windows Vista, because some users of course preferred that, it would be a support nightmare for them.

Animations are one thing, which I disabled for same reason, why I also disabled MegaBar feature, but I'm mainly talking about flashing/flickering/blinking on white some wide and large area in Address Bar, which is tiresome and exhausting on my morbid and unhealthy eyes and is affecting users with disability and diseases.

I use the dark theme for similar reasons, across the whole OS (and Firefox of course), did you try it? If you have problems with flashing white, it may be the best solution for you.
The enlarged are is not so much more prominent and your eyes are already focused on the field.
There should be no flickering, if there is le us know where so we can reduce it.
We'll discuss your feedback and take a decision.

:Virtual, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(Virtual)

Is there some discussion to read about the reasoning behind the megabar? I accidentially just reported this as a bug and I still think this is a feature that might make sense for touch devices or visually impaired people but not sth to have enabled by default. Is this sth regarded as looking good? I think it looks disruptive.

We're not going to do this.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1588724
Duplicate of this bug: 1588724

(In reply to Marco Bonardo [::mak] from comment #4)

(In reply to Virtual_ManPL [:Virtual] 🇵🇱 - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #3)

Ability to control (disable and enable) software features (especially new ones) are crucial and vital.

This is not exactly a feature, it's the design of the product, like how you present yourself to other people. If we think it doesn't serve well our users, it will be changed. Providing preferences for everything is a no-exit way, everyone has different preferences, and that's normal. On design it's also worse, because it's a lot more subjective. Imo it's not disrespectful towards users, it's just how software development works.

I understand your point of view, but I have otherwise opinion about this, and looks like, quickly looking at few discussion platforms, I'm not alone with my opinion, that there have to be preference in GUI Options/about:preferences or at last in "Customize..." mode, like it's now with "Downloads" button and its "Auto-hide" mode after long "fight" with Mozilla developers, to control also this feature.

(In reply to Marco Bonardo [::mak] from comment #4)

Think if Microsoft should allow to switch Windows graphics from the ones in Windows 10 to the one in Windows Vista, because some users of course preferred that, it would be a support nightmare for them.

I don't care what evil and bad company like Microsoft think, Mozilla shouldn't care as well, as Microsoft doesn't respect Windows users for very long time. Just quickly looking at pushing mobile touch like GUI for PCs, forced telemetry, forced and more and more buggy updates, etc. Not to mention some different and kinda blurry font rendering. These are just some of many reasons why I'm still using Windows 7. As there is no single reason for me why I should update to Windows 10, when still every software I'm using works properly. What's more, even latest hardware works properly, but need unofficial external users created hacks and patches, because Microsoft forbid and disallow it officially. For me as user, I care only about my efficiency and productivity with interaction with software I'm using, so changing crucial and vital settings and preferences to meet my needs are must have to for me.

(In reply to Marco Bonardo [::mak] from comment #4)

Animations are one thing, which I disabled for same reason, why I also disabled MegaBar feature, but I'm mainly talking about flashing/flickering/blinking on white some wide and large area in Address Bar, which is tiresome and exhausting on my morbid and unhealthy eyes and is affecting users with disability and diseases.

I use the dark theme for similar reasons, across the whole OS (and Firefox of course), did you try it? If you have problems with flashing white, it may be the best solution for you.

My system doesn't support Dark Mode, but since beginning, I always modified, customized and personalized system look, so it will looks like Dark Mode in end. If I only could use enabled Dark Mode with Themes in Firefox, but unfortunately it's not supported, as I'm seeing. But still main issue is enlargement.

(In reply to Marco Bonardo [::mak] from comment #4)

The enlarged are is not so much more prominent and your eyes are already focused on the field.
There should be no flickering, if there is le us know where so we can reduce it.
We'll discuss your feedback and take a decision.

My eyes are not focused on the field like Address Bar. I have my home website page set, when I'm starting Firefox, but also when I'm opening new tab and new window, and this flashing/flickering/blinking on white some wide and large area in Address Bar are extremely tiresome and exhausting on my morbid and unhealthy eyes and it's also affecting other users with disability and diseases, especially with vision and visual ones.

(In reply to Dão Gottwald [::dao] from comment #7)

We're not going to do this.

Too bad that Mozilla will forbid and disallow Firefox users to modify and disable MegaBar, especially when many Nightly users, looking at many discussion website pages, will like to have build-in option to disable this feature. Still it would be nice to know Mozilla arguments about this fast decision.

Duplicate of this bug: 1628888

I have a question, because, what are you doing if someone submit a patch for this ? Are you going to merge it ?

If i learn enough rust and how is build firefox i think, i can submit a patch for that… but, before i start, i want to know if you Mozilla are going to accept it and merge it inside the basecode.

So I need one response, are you accepting a patch for this BUG (because it is a bug for me) ?
A simple patch that add only one key in the about:config database, read it and if it's false change the bar to the old one.

(In reply to sam.vzh from comment #15)

I have a question, because, what are you doing if someone submit a patch for this ? Are you going to merge it ?

Because this bug is resolved as wontfix, patches are not accepted.

Duplicate of this bug: 1629484
Duplicate of this bug: 1629484
Duplicate of this bug: 1631185
Duplicate of this bug: 1631594
Duplicate of this bug: 1643388
Duplicate of this bug: 1636107
Duplicate of this bug: 1644703
Duplicate of this bug: 1629484
Restrict Comments: true
You need to log in before you can comment on or make changes to this bug.