Closed Bug 1628479 Opened 6 months ago Closed 5 months ago

Add a single-stage clang-cl toolchain task

Categories

(Firefox Build System :: Toolchains, enhancement)

enhancement
Not set
normal

Tracking

(firefox77 fixed)

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: dmajor, Assigned: dmajor)

References

Details

Attachments

(1 file)

The PGO stage in bug 1326486 made the win64-clang-cl toolchain take even longer than it already did. And unfortunately, this impacts the lead time of even the cross-compiled builds, because linux64-clang-9-win-cross depends on win64-clang-cl for its compiler-rt runtimes and a Windows-flavored clang-cl.exe for MIDL under Wine. In code review glandium suggested that the win-cross toolchain could settle for the runtimes and clang-cl.exe from a single-stage build. That would allow the cross-compile toolchain to start more quickly.

Currently the linux64-clang-9-win-cross toolchain depends on the win64-clang-cl toolchain for a few files. This causes very long lead times when toolchains are rebuilt, because of the un-parallelizable chain of tasks win64-clang-cl -> linux64-clang-9-win-cross -> builds.

As a partial mitigation, this patch adds a single-stage clang-cl build for consumption by the cross toolchain. It's not a very high quality build, but good enough for the purpose it serves, while being faster to build.

Assignee: nobody → dmajor
Status: NEW → ASSIGNED
See Also: → 1629184
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e49ad3cdea17
Add a single-stage clang-cl toolchain task r=glandium
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/8a7e67790d80
Port bug 1628479: Add single-stage clang-cl toolchain. rs=bustage-fix
Regressions: 1631627
You need to log in before you can comment on or make changes to this bug.