Closed Bug 1628851 Opened 2 years ago Closed 1 year ago

VP8 temporal scalability not working in 75/76

Categories

(Core :: WebRTC: Audio/Video, defect, P1)

75 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- wontfix
firefox76 --- fixed
firefox77 --- fixed

People

(Reporter: lennox, Assigned: dminor)

References

(Depends on 1 open bug, Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [jitsi-meet])

Attachments

(1 file)

When I turn on simulcast in WebRTC I see VP8 streams being sent with temporal scalability (TID and TL0PICIDX fields in the payload header) with Firefox 73 and 74, but not with Firefox 75 or 76.

This is with an experimental branch of Jitsi-meet which is getting close to having full Firefox support. (We can give you access if that'd be helpful.)

This regression makes it harder to get to full Firefox support for Jitsi, unfortunately...

Any chance you can narrow this down with mozregression?

mozregression returned:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3083337429be51cfd990ec1fb41fee20e8207789&tochange=649a2a4d16d088b116976231b73b3defdf6e5e5f

And it looks like the problem is actually somewhat more complicated than I thought - it looks like one of the simulcast layers is lacking simulcast support, while the other two have it.

Assignee: nobody → dminor
Status: NEW → ASSIGNED
Flags: needinfo?(dminor)
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f92781171c8
Fix VP8 temporal scalability; r=bwc
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

Hi Jonathan, this should now be fixed in Nightly. I was wondering if you could please verify that this is the case? Thank you!

Flags: needinfo?(lennox)

Yes, I can confirm the problem is fixed in Nightly.

Flags: needinfo?(lennox)

Comment on attachment 9140105 [details]
Bug 1628851 - Fix VP8 temporal scalability; r=bwc!

Beta/Release Uplift Approval Request

  • User impact if declined: Broken simulcast leading to higher bandwidth consumption and poor performance when making webrtc calls.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a small change that reverts to previous behaviour.
  • String changes made/needed: None
Attachment #9140105 - Flags: approval-mozilla-beta?

Comment on attachment 9140105 [details]
Bug 1628851 - Fix VP8 temporal scalability; r=bwc!

Fixes a regression by reverting back to previous known-good behavior. Approved for 76.0b6.

Attachment #9140105 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [jitsi-meet]
You need to log in before you can comment on or make changes to this bug.