Closed Bug 1628997 Opened 8 months ago Closed 1 month ago

It's no more possible to access list of frequently accessed pages in PB mode

Categories

(Firefox :: Address Bar, enhancement, P3)

enhancement
Points:
3

Tracking

()

RESOLVED DUPLICATE of bug 1659752

People

(Reporter: mak, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: blocked-ux, parity-safari)

In PB mode we don't open the Top Sites list, but we used to allow opening the frequent sites list with the dropmarker before. This means it's no more possible to access that list if one needs to visit one of those pages in PB mode.

Surely we don't want to automatically open the Top Sites list in PB mode, but should we still allow to open it if the urlbar is focused and the user further clicks it or uses the keyboard shortcut?

See Also: → 1627499
See Also: → 1629387

FYI, Safari shows Favorites in Private Windows if the address bar is focused on a page other than their equivalent of about:privatebrowsing.

Their version of about:privatebrowsing actually looks pretty much like a normal window - I see "Top Sites" there. I think this explains why they don't show it on new tabs - it would be duplicating what is shown in the tab.

This is kind of a confusing bug. Not sure if it is asking for the ^ list, or the dropmarker, or top sites optionally with support for ^. Just wanted to add some information about what Safari does in any case.

Keywords: parity-chrome
See Also: 1629387
See Also: → 1629387
Blocks: 1630275

(In reply to Marco Bonardo [:mak] from comment #0)

In PB mode we don't open the Top Sites list, but we used to allow opening the frequent sites list with the dropmarker before. This means it's no more possible to access that list if one needs to visit one of those pages in PB mode.

Surely we don't want to automatically open the Top Sites list in PB mode, but should we still allow to open it if the urlbar is focused and the user further clicks it or uses the keyboard shortcut?

There are workarounds for PB mode. You can make Top Sites show by typing a character and then deleting it. You can show the frecent list by typing ^.

Points: --- → 3
Depends on: 1629387
Severity: normal → S3

With Bug 1659752 we made TopSites open also in private windows, so this has now a solution.

Status: NEW → RESOLVED
Closed: 1 month ago
Depends on: 1659752
Resolution: --- → DUPLICATE
Duplicate of bug: 1659752
No longer depends on: 1659752
You need to log in before you can comment on or make changes to this bug.