Closed Bug 1629387 Opened 8 months ago Closed 1 month ago

Evaluate ways to have top sites and frecent sites coexist

Categories

(Firefox :: Address Bar, enhancement, P3)

enhancement

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox77 --- affected

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: losing-users)

I thought the comments on bug 1628024 and the issues described in bug 1628997 begged for a more obvious solution that was being danced around.

Per my comment in bug 1627858:

If we want to retain history (like the old address bar), I think it makes a lot more sense to just bring back the disclosure triangle, like Firefox <75 and current Vivaldi. That way, it retains the same UX it has always had, remains discoverable and can coexist with the new top sites behavior. That requires more thinking though, and is out of scope for what I am suggesting here (File a new bug if you are interested in thinking this through! - I personally never used it.)

I guess I am filing that bug after all!

When I first proposed bug 1558000, I had not imagined that the dropmarker would go away - rather, we'd be adding a new top sites feature. Nor had I expected that enabling top sites would mean that ^ would go away.

Per comment 11 on bug 1628024:

The old list can still be used, if you disable Top Sites in the New Tab Page, or with the ^ workaround.

This is already a supported list in the address bar, showing the dropmarker is very similar to the "Search Tabs" menu item in the tab bar drop marker (which adds % to the address bar) - why not do the same thing here?

Why should users be forced to choose between top sites and ^? I see use cases for both, and while I basically never used the drop marker, I use % constantly and appreciate the discoverability added in the menu item.

This would be a simple solution and I think users would appreciate it if it were brought back. It could even be hidden by default, like "Copy Link" (for example) and restored for people who like that list.

See Also: → 1628997
See Also: → 1628024
See Also: 1628997
See Also: → 1628997

We're investigating the request to make the old list available, I must note though that it's sufficient to unpin pages from the new Tab page to make it default to the most frecent pages, that is more or less the old list.

I'm modifying the bug to that, because I don't think the dropmarker will come back (that'd be a wontfix).

Summary: Bring back the address bar drop marker so that top sites and frecent sites can coexist → Evaluate ways to have top sites and frecent sites coexist
Priority: -- → P3

Some considerations extracted from Bug 1627858:

  1. Top Sites can be populated by users manually - and I would think a design goal of Top Sites in general is to promote and facilitate this. Remember that two "Top Sites" are pinned by default in en-us (or has been) - Amazon and Google searches - which are not at all necessarily frecent. When Top Sites are customized by users, they can differ extensively from the drop marker's frecent url list.
  2. If you already plan to add a toggle to about:preferences#search to enable/disable Top Sites, you could easily have one for the drop marker. Vivaldi includes this as a preference.
  3. I have seen some mockups showing an omnipresent magnifying glass icon near the awesomebar that presumably adds ? to the awesomebar input. The dropmarker could do the same thing for ^. It doesn't seem like that huge a lift for something where developers have given no indication of removing support for ^ -- if it is a supported function, what is the harm in making it discoverable or easily accessible? It could even be disabled by default.

Two posts from people specifically missing the old frecent sites list:

https://www.reddit.com/r/firefox/comments/gvyivk/how_to_revert_new_address_bar_change/
https://www.reddit.com/r/firefox/comments/gvdwzn/why_is_mozilla_forcing_us_to_use_the_megabar/fsrtnka/

The dropdown arrow would give vastly different results to "megabar" as it was a list of common urls instead of "top" "sites" that you go to which is honestly just trash. It brings in stuff that I honestly don't visit that often like 192.168.1.1 since most of my urls were subreddits. If you had a list of frequently visted urls and you were used to just clicking the drop down arrow and checking out your pages well fuck you. I had 6 different subreddits on my dropdown arrow and a few, get this, other relevant urls that I would frequently visit. Now reddit/games is at the top and the rest of the list is full of pointless shit like my router. Want your dropdown back? Want customization? No. You get top sites.

This user then posted an image of the Firefox uninstaller with a note that they had used Firefox for nearly 20 years.

Keywords: losing-users

167 net votes and a lot of comments in support of this feature: https://www.reddit.com/r/firefox/comments/gw5hfq/to_ff_devs_please_bring_back_the_drop_down/

We think we identified a way to have the lists cohexist, that is based on the work that will happen in bug 1644572, though we still need some time to define all the requirements and specifications. Details are lacking, we know, but it's work we're defining right now.

Severity: -- → S3

Now the urlbar includes a button to search History, that pretty much by default shows the old list of most frecent pages. In addition Top Sites are now shown also in Private windows.

The only negative here, is that the old list is 2 clicks instead of one (or CTRL+L followed by ALT+UP), but there's also add-ons the reimplement the old dropdown menu as a toolbar button (I think the most famous one has about 400 users).
I think there's enough options to address most of the concerns here, more specific suggestions could be filed apart. At this time we don't plan to bring back the dropmarker anyway.

So, this now works as intended, please let us know if you have suggestions to further improve the current state.
Note we still plan to allow editing Top Sites directly in the urlbar, or at least make it clearer where those entries come from and how to remove them.

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.