Closed Bug 1629181 Opened 3 years ago Closed 2 years ago

Crash in [@ IPCError-browser | CommonCreateWindow Passed-in OriginAttributes does not match opener]

Categories

(Core :: DOM: Navigation, defect)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1638793

People

(Reporter: mccr8, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-2afdabc7-584c-460f-866a-4c3830200409.

Top 10 frames of crashing thread:

0 ntdll.dll RtlEnterCriticalSection 
1 mozglue.dll arena_t::MallocSmall memory/build/mozjemalloc.cpp:2844
2 mozglue.dll static Allocator<MozJemallocBase>::malloc memory/build/malloc_decls.h:51
3 mozglue.dll replace_malloc memory/replace/phc/PHC.cpp:1122
4 xul.dll fallible::try_double_small_vec<[style::stylist::Rule; 1]> servo/components/fallible/lib.rs:145
5 xul.dll style::stylist::CascadeData::add_stylesheet<style::gecko::data::GeckoStyleSheet> servo/components/style/stylist.rs:2078
6 xul.dll geckoservo::glue::Servo_StyleSet_FlushStyleSheets servo/ports/geckolib/glue.rs:1921
7 xul.dll mozilla::ServoStyleSet::UpdateStylist layout/style/ServoStyleSet.cpp:1134
8 xul.dll mozilla::PresShell::DoFlushPendingNotifications layout/base/PresShell.cpp:4125
9 xul.dll nsRefreshDriver::Tick layout/base/nsRefreshDriver.cpp:2041

Flags: needinfo?(nika)

It looks like this first showed up in the 20200408033650 build. This is the set of changes for that build: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=de63e64b9090789daea9ad11d3cd11b4f284afe5&tochange=6663d3dc883b6ad0d0dfa9346f9ceabf2b2c7967

Sounds like it could be a regression from bug 1616353.

Crash Signature: [@ IPCError-browser | CommonCreateWindow Passed-in OriginAttributes does not match opener] It looks like this first showed up in the 20200408033650 build. This is the set of changes for that build: https://hg.mozilla.org/mozilla-central/pushloghtml?fro… → [@ IPCError-browser | CommonCreateWindow Passed-in OriginAttributes does not match opener]

I'm getting this crash every time a browser extension tries to use window.open.

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → --

I think this has been fixed now in bug 1638793.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(nika)
Resolution: --- → DUPLICATE
Duplicate of bug: 1638793
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.