Closed Bug 1630167 Opened 5 months ago Closed 5 months ago

Loading spinner animates forever if tabs is discarded while loading

Categories

(Firefox :: Tabbed Browser, defect, P1)

76 Branch
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 77
Iteration:
77.1 - Apr 6 - Apr 19
Tracking Status
firefox77 --- verified

People

(Reporter: perso, Assigned: dao)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

  1. Install tabs-tabs-tabs[1], Tab Center Reborn[2] or any other extension that has the tabs permission
    [1]: https://github.com/mdn/webextensions-examples/tree/master/tabs-tabs-tabs
    [2]: https://addons.mozilla.org/firefox/addon/tabcenter-reborn/
  2. Type await browser.tabs.query({}); and get the id of a tab you can discard
  3. Type await browser.tabs.reload(tabId); setTimeout(() => browser.tabs.discard(tabId), 30); by using the the tab id of above.

Note that this is not a theoretical case I can trigger it by doing F5 and unloading the tab with an extension that adds a context menu entry to do that.

Actual results:

Tab is discarded but the loading spinner doesn’t go away.

await browser.tabs.get(tabId); reports the tab as both discarded: true and status: loading.

Expected results:

– Discarded tab get back its favicon, instead of the loading spinner.
– WebExtensions API reports its status as complete instead of loading like for other discarded tabs.

I wrote this whole report just to see that it has already been reported as bug 1611878.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Frontend
Product: Firefox → WebExtensions

This is an issue in tabbrowser.

Component: Frontend → Tabbed Browser
Product: WebExtensions → Firefox
Assignee: nobody → dao+bmo
Blocks: 1611878
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 77.1 - Apr 6 - Apr 19
Points: --- → 2
Ever confirmed: true
Priority: -- → P1

Resetting severity to default of --.

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/501574a6e645
Remove busy, progress, pendingicon attributes when discarding browser. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
Duplicate of this bug: 1450371
Blocks: 1634040
Flags: qe-verify+

Verified- Fixed on latest Nightly 78.0a1 and Beta 77.0b3

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.