Closed Bug 1630171 Opened 1 year ago Closed 1 year ago

Intermittent browser/components/newtab/test/browser/browser_aboutwelcome_observer.js | Uncaught exception - [Exception... "Component is not available" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: JS frame :: browser_aboutwelcome_observer.js

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 77
Iteration:
77.1 - Apr 6 - Apr 19
Tracking Status
firefox76 --- fixed
firefox77 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: pdahiya)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered])

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=297680705&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/HhXXi3lFS82PgfUoHv9CRw/runs/0/artifacts/public/logs/live_backing.log


[task 2020-04-15T05:37:51.259Z] 05:37:51 INFO - TEST-START | browser/components/newtab/test/browser/browser_aboutwelcome_observer.js
[task 2020-04-15T05:37:51.285Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x14b2cc800 == 13 [pid = 1787] [id = {c97d490f-92b7-c54a-8ad3-cc505ef74aa6}]
[task 2020-04-15T05:37:51.285Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 37 (0x112afd200) [pid = 1787] [serial = 37] [outer = 0x0]
[task 2020-04-15T05:37:51.285Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 38 (0x14b328c00) [pid = 1787] [serial = 38] [outer = 0x112afd200]
[task 2020-04-15T05:37:51.367Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 37 (0x11d80c800) [pid = 1787] [serial = 5] [outer = 0x0] [url = about:blank]
[task 2020-04-15T05:37:51.369Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 36 (0x11d8ed000) [pid = 1787] [serial = 8] [outer = 0x0] [url = about:blank]
[task 2020-04-15T05:37:51.369Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 35 (0x120833400) [pid = 1787] [serial = 14] [outer = 0x0] [url = about:blank]
[task 2020-04-15T05:37:51.369Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 34 (0x120754800) [pid = 1787] [serial = 11] [outer = 0x0] [url = about:blank]
[task 2020-04-15T05:37:51.369Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 33 (0x112a6a800) [pid = 1787] [serial = 2] [outer = 0x0] [url = about:blank]
[task 2020-04-15T05:37:51.387Z] 05:37:51 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 34 (0x11d8ec400) [pid = 1787] [serial = 39] [outer = 0x112afd200]
[task 2020-04-15T05:37:51.457Z] 05:37:51 INFO - GECKO(1775) | [1792, MainThread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/checkouts/gecko/xpcom/base/nsTraceRefcnt.cpp, line 202
[task 2020-04-15T05:37:51.457Z] 05:37:51 INFO - GECKO(1775) | [1792, MainThread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/checkouts/gecko/xpcom/base/nsTraceRefcnt.cpp, line 202
[task 2020-04-15T05:37:51.457Z] 05:37:51 INFO - GECKO(1775) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /var/folders/_t/k5bnz3rn79q442jjl1g2z4n0000017/T/tmplorJGv.mozrunner/runtests_leaks_tab_pid1792.log
[task 2020-04-15T05:37:51.457Z] 05:37:51 INFO - GECKO(1775) | [1792, MainThread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/checkouts/gecko/xpcom/base/nsTraceRefcnt.cpp, line 202
[task 2020-04-15T05:37:51.457Z] 05:37:51 INFO - GECKO(1775) | [1792, MainThread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/worker/checkouts/gecko/xpcom/base/nsTraceRefcnt.cpp, line 202
[task 2020-04-15T05:37:51.458Z] 05:37:51 INFO - GECKO(1775) | [1792, Main Thread] WARNING: XPCOM_MEM_BLOAT_LOG is set, disabling native allocations.: file /builds/worker/checkouts/gecko/tools/profiler/core/platform.cpp, line 221
[task 2020-04-15T05:37:52.198Z] 05:37:52 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x119fdbc00 == 14 [pid = 1787] [id = {95cfc2e0-e11b-3d4d-871f-846eac04150d}]
[task 2020-04-15T05:37:52.198Z] 05:37:52 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 35 (0x12507ee40) [pid = 1787] [serial = 40] [outer = 0x0]
[task 2020-04-15T05:37:52.198Z] 05:37:52 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 36 (0x11b762000) [pid = 1787] [serial = 41] [outer = 0x12507ee40]
[task 2020-04-15T05:37:52.284Z] 05:37:52 INFO - TEST-INFO | started process screencapture
[task 2020-04-15T05:37:52.428Z] 05:37:52 INFO - TEST-INFO | screencapture: exit 0
[task 2020-04-15T05:37:52.428Z] 05:37:52 INFO - Buffered messages logged at 05:37:51
[task 2020-04-15T05:37:52.428Z] 05:37:52 INFO - Entering test bound test_About_Welcome_Tab_Close
[task 2020-04-15T05:37:52.429Z] 05:37:52 INFO - TEST-PASS | browser/components/newtab/test/browser/browser_aboutwelcome_observer.js | Active window is not null - [object ChromeWindow] == true -
[task 2020-04-15T05:37:52.429Z] 05:37:52 INFO - TEST-PASS | browser/components/newtab/test/browser/browser_aboutwelcome_observer.js | AboutWelcomeObserver is not null - [object Object] == true -
[task 2020-04-15T05:37:52.437Z] 05:37:52 INFO - TEST-PASS | browser/components/newtab/test/browser/browser_aboutwelcome_observer.js | Terminated due to tab closed - "welcome-tab-closed" == "welcome-tab-closed" -
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - Leaving test bound test_About_Welcome_Tab_Close
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - Entering test bound test_About_Welcome_Location_Change
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - Buffered messages finished
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - TEST-UNEXPECTED-FAIL | browser/components/newtab/test/browser/browser_aboutwelcome_observer.js | Uncaught exception - [Exception... "Component is not available" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_aboutwelcome_observer.js :: test_About_Welcome_Location_Change :: line 60" data: no]
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - Stack trace:
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - test_About_Welcome_Location_Change@chrome://mochitests/content/browser/browser/components/newtab/test/browser/browser_aboutwelcome_observer.js:60:47
[task 2020-04-15T05:37:52.438Z] 05:37:52 INFO - AsyncTester_execTest/<@chrome://mochikit/content/browser-test.js:1039:34
[task 2020-04-15T05:37:52.439Z] 05:37:52 INFO - async
Tester_execTest@chrome://mochikit/content/browser-test.js:1074:11
[task 2020-04-15T05:37:52.439Z] 05:37:52 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:904:14
[task 2020-04-15T05:37:52.439Z] 05:37:52 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:918:23
[task 2020-04-15T05:37:52.439Z] 05:37:52 INFO - Leaving test bound test_About_Welcome_Location_Change
[task 2020-04-15T05:37:52.439Z] 05:37:52 INFO - GECKO(1775) | [Child 1787: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 37 (0x14b4d7800) [pid = 1787] [serial = 42] [outer = 0x12507ee40]
[task 2020-04-15T05:37:52.439Z] 05:37:52 INFO - GECKO(1775) | console.warn: AboutWelcomeParent.jsm: Not handling AWPage:LOCATION_CHANGED because the browser doesn't exist.
[task 2020-04-15T05:37:52.440Z] 05:37:52 INFO - GECKO(1775) | MEMORY STAT | vsize 7641MB | residentFast 340MB | heapAllocated 139MB
[task 2020-04-15T05:37:52.440Z] 05:37:52 INFO - TEST-OK | browser/components/newtab/test/browser/browser_aboutwelcome_observer.js | took 1058ms

Flags: needinfo?(pdahiya)
Regressed by: 1628094

It appears this intermittent is due to AboutWelcome actor not available to WindowGlobalParent before used in test, will look into it and submit fix. Thanks

Flags: needinfo?(pdahiya)
Assignee: nobody → pdahiya
Status: NEW → ASSIGNED
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c40440a097e
Fix intermittent due to AboutWelcome actor not available r=mconley

[Tracking Requested - why for this release]:

Priority: P5 → P1
Iteration: --- → 77.1 - Apr 6 - Apr 19
Whiteboard: [retriggered]
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

Comment on attachment 9140878 [details]
Bug 1630171 - Fix intermittent due to AboutWelcome actor not available

Beta/Release Uplift Approval Request

  • User impact if declined: Fixes intermittent test failure seen with test added in bug 1628094 .
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1628094
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch that fixes intermittent test failure seen with 1628094 which is beta uplift approved. This patch should be uplifted and applied after 1628094 fix.
  • String changes made/needed: None
Attachment #9140878 - Flags: approval-mozilla-beta?

Comment on attachment 9140878 [details]
Bug 1630171 - Fix intermittent due to AboutWelcome actor not available

Approved for 76.0b6.

Attachment #9140878 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.