Closed Bug 1630515 Opened 1 year ago Closed 1 year ago

One click in the adressbar of a given page does highlight the address but NOT copy it into the clipboard anymore (like it used to).

Categories

(Firefox :: Address Bar, defect)

75 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 333714

People

(Reporter: ThomasvonderElbe, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

click in the adressbar

Actual results:

the adress of a given page gets highlighted

Expected results:

the adress should get highlightedbut AND get copied into the clipboard (like it used to)

This is expected behavior at this point (see bug 1628081 for a similar report).

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: Untriaged → Address Bar
Resolution: --- → DUPLICATE
Duplicate of bug: 333714

because the selection is programmatic, and not user-done, we don't set the primary clipboard. To set the primary clipboard you can triple click, like in any textbox, or you can select manually parts of the url.

What is a difference between single and triple click in regard to differentiating between "user-done" and "programmatic" selection ?

Every selection is programmatic and happens as a consequence of user action. You have just decided that singleClick will not copy selection to primary.

BTW - you have mentioned some plans in bug 1621570 about changing the behaviour of unfocused address bar. Is there any place where we could read about these plans ? I'd ask there but you restricted comments...

You need to log in before you can comment on or make changes to this bug.