Closed Bug 1631577 Opened 4 months ago Closed 3 months ago

Cannot delete entries within Customize Headers

Categories

(Thunderbird :: Search, defect, P2)

Tracking

(thunderbird_esr68 fixed, thunderbird77 fixed)

RESOLVED FIXED
Thunderbird 78.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird77 --- fixed

People

(Reporter: bug.zilla, Assigned: khushil324)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Hi,

I added a few custom headers to search for some messages.
I'm now unable to delete those entries from the drop-down menu.

If I select Remove from the Customise Headers menu they disappear, but once I click OK they reappear in the drop down menu options again.

I've tried in Safe Mode as well.

I can confirm this is broken.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P2
Summary: Cannot delete entries within Customise Headers search → Cannot delete entries within Customize Headers
Assignee: nobody → khushil324
Attachment #9147731 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Comment on attachment 9147731 [details] [diff] [review]
Bug-1631577-fix-delete-custom-headers-0.patch

Review of attachment 9147731 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/base/search/content/CustomHeaders.js
@@ +163,5 @@
>  }
>  
>  function GetListItemAttributeStr(listitem) {
>    if (listitem) {
> +    return TrimString(listitem.firstChild.getAttribute("value"));

I think this should be firstElementChild to be sure

And while we're here, let's just use normal trim().

listitem.firstElementChild.getAttribute("value").trim();

Oh, and GetListItemAttributeStr is only ever called one time. Never with null. 
Let's just inline the call instead...
Attachment #9147731 - Flags: review?(mkmelin+mozilla) → review+
Attachment #9147731 - Attachment is obsolete: true
Attachment #9147768 - Flags: review+

We need to land it for ESR 68 as well as Daily.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/03319b23c7f9
Fix Cannot delete entries within Customize Headers. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 78.0
Attachment #9147768 - Flags: approval-comm-esr68?
Attachment #9147768 - Flags: approval-comm-beta?
Comment on attachment 9147768 [details] [diff] [review]
Bug-1631577-fix-delete-custom-headers-1.patch

approved for beta
Attachment #9147768 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9147768 [details] [diff] [review]
Bug-1631577-fix-delete-custom-headers-1.patch

[Triage Comment]
Approved for ESR
Attachment #9147768 - Flags: approval-comm-esr68? → approval-comm-esr68+
Duplicate of this bug: 1650529
You need to log in before you can comment on or make changes to this bug.