Closed Bug 1631848 Opened 1 year ago Closed 1 year ago

Increase number of Top Sites in the urlbar when more rows are shown in the New Tab Page

Categories

(Firefox :: Address Bar, task, P3)

task
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 79
Iteration:
79.1 - June 1 - June 14
Tracking Status
firefox79 --- fixed

People

(Reporter: harry, Assigned: mak)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We show eight Top Sites to match the number of Top Sites that most users see on the New Tab page. When we initially designed the Top Site feature, we decided to show eight Top Sites instead of browser.urlbar.maxRichResults (default 10). Since the Top Sites list is customizable, it might confuse some users that the first eight Top Sites that appear in the Urlbar also appear on the New Tab Page and are customizable, but the last two seemingly appear from nowhere. Users that don't know that you can show more than eight Top Sites on the New Tab Page might never figure out how to customize those last two results.

Since launching the new address bar, we've heard from users that they'd like to see more than eight Top Sites. We're evaluating ways to accommodate this. So far, we've discussed simply showing maxRichResults Top Sites, doing so after implementing a basic editing UI for Urlbar Top Sites, or adding a new pref for this (browser.urlbar.maxRichResults.topSites, perhaps?).

Priority: -- → P3

We could also respect maxRichResults only if it has been changed, so if it's at the default value we show 8, if changed we adapt to its value (and assume the user knows what they're doing). We should likely also put a limit to maxRichResults, just crop it to 24 (I know some users have it set higher, but there's performance reasons for which we don't want to go that high).

There is continued interest in this: https://www.reddit.com/r/firefox/comments/ghdkat/display_more_than_8_suggested_website_in_the/

Is there a way to change the number of websites that are suggested when I click on the search/address bar ? At the moment 8 are suggested, I'd like to display more. The suggested websites are those pinned in the Top Sites section of the new tab page but I have more than 8 pinned.

This will be much easier to support once Top Sites can be managed from the urlbar itself, then we could just respect maxRichResults. Alternatively we could respect maxRichResults if it's < num_rows * 8.

That's just my opinion anyway, it still requires an UX call.

Duplicate of this bug: 1643559

After discussing about this again today, I'll implement logic for which the number of Top Sites shown in urlbar will be min(topSitesInNewTabPage, maxRichResults), this won't completely solve the problem but will allow for a way to show more Top Sites. For most users it won't make a noticeable difference.

Assignee: nobody → mak
Status: NEW → ASSIGNED
Keywords: blocked-ux
Iteration: --- → 79.1 - June 1 - June 14
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/6be570e963de
Increase number of Top Sites in the urlbar when more rows are shown in the New Tab Page. r=harry
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
Summary: Evaluate increasing the number of Top Sites shown in the Urlbar → Increase number of Top Sites in the urlbar when more rows are shown in the New Tab Page
Duplicate of this bug: 1649826
Duplicate of this bug: 1654410
You need to log in before you can comment on or make changes to this bug.