Closed Bug 1649826 Opened 2 years ago Closed 2 years ago

browser.urlbar.maxRichResults value is ignored in v78

Categories

(Firefox :: Address Bar, defect)

78 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1631848

People

(Reporter: frutoso7, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Prior to v78, 15 lines used to show underneath the address bar when I clicked on it, as per my "browser.urlbar.maxRichResults" value of 15.

Actual results:

In v78 the amount of lines shown underneath the address bar now appears to be limited to 7.

Expected results:

I believe Firefox should have respected my "browser.urlbar.maxRichResults" value of 15.

The add-on "Show History Frequent Sites Button" mimics what I would expect, although I should not have to resort to add-ons in order to fix problems introduced in new versions Firefox.

Whatever happened to listening to the end user?

Summary: browser.urlbar.maxRichResults value is ignore in v78 → browser.urlbar.maxRichResults value is ignored in v78
Component: Untriaged → Address Bar

I suspect you're talking about Top Sites that appear when there's no typed value in the urlbar (or it contains the current page url).

If you start typing in the urlbar do you see the correct number of results?

Flags: needinfo?(frutoso7)

(In reply to Marco Bonardo [:mak] from comment #1)

I suspect you're talking about Top Sites that appear when there's no typed value in the urlbar (or it contains the current page url).

If you start typing in the urlbar do you see the correct number of results?

Yes that is correct. If I click on the address bar and press space, then I can see the top sites which were present in v77.x.

Sadly something has change in v78.x, resulting in only 7 top sites now being shown below the address bar.

I hope this can be resolved without the need for add-ons.

Flags: needinfo?(frutoso7)

(In reply to Dalegica from comment #2)

Yes that is correct. If I click on the address bar and press space, then I can see the top sites which were present in v77.x.

Sadly something has change in v78.x, resulting in only 7 top sites now being shown below the address bar.

So, Top Sites is the only thing that you can show when the urlbar is empty or contains the current page uri. If you disable Top Sites in about:preferences you won't see anything.
These Top Sites used to be limited at 8 or less, and they can be fully customized in the New Tab Page or, if you unpin all the sites, they will update automatically based on visits/bookmarks.
In Firefox 79 we fixed bug 1631848, that allows Top Sites to respect maxRichResults, provided those pages are also visible in the New Tab Page (This is to avoid confusing users about where additional rows came from).

Thus, from Firefox 79 if you want to see maxRichResults Top Sites you will just enable 3 Top Sites rows in about:preferences#home. You can also hide or disable Top Sites in the New Tab Page if you don't want them there, the only thing that matters is that you set Top Sites to 3 rows.
For now that's what we have, one day it will be possible to manage Top Sites directly from the urlbar and then we'll be able to drop these connections with the New Tab Page.

I'm duping to bug 1631848, because that's the current solution we can provide to this problem, we'll do better in the future with upcoming changes.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1631848

(In reply to Marco Bonardo [:mak] from comment #3)

(In reply to Dalegica from comment #2)

Yes that is correct. If I click on the address bar and press space, then I can see the top sites which were present in v77.x.

Sadly something has change in v78.x, resulting in only 7 top sites now being shown below the address bar.

So, Top Sites is the only thing that you can show when the urlbar is empty or contains the current page uri. If you disable Top Sites in about:preferences you won't see anything.
These Top Sites used to be limited at 8 or less, and they can be fully customized in the New Tab Page or, if you unpin all the sites, they will update automatically based on visits/bookmarks.
In Firefox 79 we fixed bug 1631848, that allows Top Sites to respect maxRichResults, provided those pages are also visible in the New Tab Page (This is to avoid confusing users about where additional rows came from).

Thus, from Firefox 79 if you want to see maxRichResults Top Sites you will just enable 3 Top Sites rows in about:preferences#home. You can also hide or disable Top Sites in the New Tab Page if you don't want them there, the only thing that matters is that you set Top Sites to 3 rows.
For now that's what we have, one day it will be possible to manage Top Sites directly from the urlbar and then we'll be able to drop these connections with the New Tab Page.

I'm duping to bug 1631848, because that's the current solution we can provide to this problem, we'll do better in the future with upcoming changes.

*** This bug has been marked as a duplicate of bug 1631848 ***

I'm not entirely sure I understand, perhaps you haven't explained enough or I haven't been descriptive enough?

I am not talking about new tab pages. I am talking about the drop down "Top Sites" list in the address bar which appears when you the click on the address bar from any page, website or new tab.

I do not use the new tab page, therefore I am not talking about the new tab page and never have done.

Can you please provide me instructions that tell me how to display the top 15 sites again, when v77 of Firefox respected the browser.urlbar.maxRichResults setting? Perhaps your instructions above have already told me how, but it is not entirely obvious or clear.

(In reply to Dalegica from comment #4)

I am not talking about new tab pages. I am talking about the drop down "Top Sites" list in the address bar which appears when you the click on the address bar from any page, website or new tab.

It's the same thing; the urlbar and the new tab page use the same set of results, so you can open about:home, customize the Top Sites as you wish, and then close it and keep not using it, if you wish, it doesn't matter.
In the future the list will be manageable directly from the urlbar, but that's not coded yet.

Can you please provide me instructions that tell me how to display the top 15 sites again, when v77 of Firefox respected the browser.urlbar.maxRichResults setting? Perhaps your instructions above have already told me how, but it is not entirely obvious or clear.

The only way is to wait for Firefox 79 in 4 weeks (or move to Beta, but that's up to you) and then increase the number of Top Sites rows, thus open about:home, click on the gear icon, then increase number of Rows for Top Sites from 1 to 3.

In the meanwhile for Firefox 78 the only workaround is to type ^ or a space in the urlbar.

Having updated Firefox to v79.0 (stable), I can confirm that this issue has now been resolved for me.

You need to log in before you can comment on or make changes to this bug.