Closed Bug 163249 Opened 17 years ago Closed 17 years ago

Creatig WYSIWYG Editor for Browser

Categories

(Core :: Editor, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

()

VERIFIED DUPLICATE of bug 97284

People

(Reporter: roland.sippel, Assigned: kinmoz)

References

()

Details

Attachments

(1 file)

At this time it is not possible to use Mozilla for ANY Content Managementsystem
which use a web-based WYSIWYG Editor. ALL CMS i know only support Internet
Explorer for use.
You also can not develop an WYSIWYG Editor for Mozilla with JavaScript or DHTML
because there is no Engine which you use for this.

- See upper URL with Mozi and wiht IE.

- See: http://www.typo3.com (only for IE - see WYSIWYG jpg attach)

See also: -
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/wcehtml/htm/cerefInternetExplorerMSHTMLDHTMLAPIs.asp

Hope i can use Mozi in future on a webbased Content Managementsystem.
Attachment #95710 - Attachment description: Content Mangagement WYSIWYG Editor only for IE → Content Management WYSIWYG Editor only for IE
I suppose this is contenteditable, bug 97284 (bug 147575)
Assignee: Matti → kin
Component: Browser-General → Editor: Core
QA Contact: asa → sujay
Who says that it isnt possible to develop a WYSIWYG editor for Mozilla with
DHTML?Go to http://www.xopus.org/index.jsp?menu=mozce,you can edit it
(contenteditable) and with Ctrl+B/Ctrl+I you can make even make the selected
text bold/italic (WYSIWYG).
Very cool - try to do this with a form and textarea box ?
In a Content Managementsystem the Edit Text are in a textarea !!
(see my attach)

You try the online demo with mozi: 
http://lime.platvorm.com/lime ???
Bosko:
That editor is far from having all the possibilities that IE has.

Roland:
Your comment in 97284 wasn't really needed. No one has said that it won't be
added it's just a matter of time/resources.

*** This bug has been marked as a duplicate of 97284 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.