Closed Bug 1632608 Opened 4 months ago Closed 3 months ago

[wpt-sync] Sync PR 23211 - WPT Chromium logger bug fixes to integrate with results viewer.

Categories

(Testing :: web-platform-tests, task, P4)

task

Tracking

(firefox77 fixed)

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 23211 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/23211
Details from upstream follow.

Luke Zielinski <lpz@chromium.org> wrote:

WPT Chromium logger bug fixes to integrate with results viewer.

Three main issues fixed here:

  1. Removing a trailing whitespace in the "expected" field. This is
    caused by "known_intermittent" always being present in the test_end data
    dict, but simply being empty when no intermittent statuses exist.
  2. Making sure the start timestamp is always in seconds - the wpt test
    framework provides it in microseconds, but we can fallback to "now"
    which returns seconds.
  3. All artifacts are expected to be lists.

Bug: 1070265
Change-Id: I3dc98f8e37d847727c3165ab51c293f529d3c5eb
Reviewed-on: https://chromium-review.googlesource.com/2163065
WPT-Export-Revision: c27f9706e92605a4b48b833087bcf438bf56028a

The PR was not expected to affect any tests, but the try push wasn't a success. Check the try results for infrastructure issues
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/31e479ea7605
[wpt PR 23211] - WPT Chromium logger bug fixes to integrate with results viewer., a=testonly
Test result changes from PR not available.
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/f2f8da81f9bb
[wpt PR 23211] - WPT Chromium logger bug fixes to integrate with results viewer., a=testonly
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
You need to log in before you can comment on or make changes to this bug.