Closed Bug 1632647 Opened 4 months ago Closed 3 months ago

:is() and :where() shouldn't parse combinators in :host selectors.

Categories

(Core :: CSS Parsing and Computation, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(1 file)

:is() and :where() I believe right now allow you to write:

:host(:is(div .foo))

Which breaks encapsulation of the shadow tree and is wrong. We should probably not allow combinators in there (or never match, I guess, though not allowing it seems more consistent with what :host already does).

Duplicate of this bug: 1632648
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/df17138614f6
Fix parsing of :is() and :where() to account for constraints from parent selectors. r=heycam
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/23711 for changes under testing/web-platform/tests
Depends on: 1639533

Seems like an error downloading chromedriver :)

Flags: needinfo?(emilio) → needinfo?(james)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Upstream PR was closed without merging
Upstream PR merged by moz-wptsync-bot
Flags: needinfo?(james)
You need to log in before you can comment on or make changes to this bug.