Closed Bug 1633555 Opened 3 months ago Closed 3 months ago

Loss of focus after unselecting a selected recipient pill with Ctrl+Click blocks keyboard access to pills

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 78.0

People

(Reporter: bugzilla2007, Assigned: bugzilla2007)

References

(Blocks 1 open bug)

Details

(Keywords: access, ux-consistency)

Attachments

(1 file)

Loss of focus after unselecting a selected pill with Ctrl+Click. Focus must remain on the Ctrl-clicked pill. Loss of focus then prevents any further keyboard action on (selected/other) pills.

Severity: -- → normal

The fix.

Not sure about the original purpose of pill.blur here?

From my analysis, (after this bug) the whole conditional was no longer needed (noop) , because we can't blur a pill which we know has focus either from mouse click (checkSelected claims to handle mouse events only) or from pressing " " on an already focused pill. Focus is already there (no need to focus), and it must stay right there (no need to blur).

Assignee: nobody → bugzilla2007
Attachment #9145535 - Flags: review?(alessandro)
Status: NEW → ASSIGNED
Comment on attachment 9145535 [details] [diff] [review]
1633555_recipientPillCtrlClick.diff

Review of attachment 9145535 [details] [diff] [review]:
-----------------------------------------------------------------

That blur/focus condition was implemented right at the beginning, when tho whole focus/selected paradigm wasn't properly fledged out.
You improved this part a lot, so that old condition was interfering.
Good catch, thanks for fixing this.
Attachment #9145535 - Flags: review?(alessandro) → review+
Target Milestone: --- → Thunderbird 78.0

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/06b4fa036ccd
Prevent loss of focus after Ctrl+Click on recipient pills. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

(In reply to Alessandro Castellani (:aleca) from comment #2)

Review of attachment 9145535 [details] [diff] [review]:
...
You improved this part a lot, so that old condition was interfering.
Good catch, thanks for fixing this.

Most welcome. I am here to help. Fast fix, fast check-in in comment 3... : great! :-)

Blocks: 1602397
Depends on: 440377
Regressions: 1645643
You need to log in before you can comment on or make changes to this bug.