Closed Bug 1634294 Opened 1 year ago Closed 1 year ago

Dotted artifacts appear in the toolbar (Win10: Intel HD Graphics 520, 26.20.100.7263 from 2019-09-25)

Categories

(Core :: Graphics: WebRender, defect, P3)

77 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed

People

(Reporter: dekeltal, Assigned: kvark)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community)

Attachments

(4 files)

Attached image Screenshot

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

Not sure of the exact scenario, happens occasionally

Actual results:

Some "dotted artifacts" appear, usually on the toolbar.
I used to have this issue, and it was fixed
See: https://bugzilla.mozilla.org/show_bug.cgi?id=1603515

Component: Untriaged → Graphics: WebRender
Product: Firefox → Core
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: Dotted artifacts appear in the toolbar → Dotted artifacts appear in the toolbar (Win10: Intel HD Graphics 520, 26.20.100.7263 from 2019-09-25)
See Also: → 1634171

Can you go to about:config, look for gfx.webrender.compositor and if that is true, flip it to false. Restart, and let me know if you still see this issue?

Flags: needinfo?(dekeltal)

https://downloadcenter.intel.com/download/29530/Intel-Graphics-Windows-10-DCH-Drivers

Does it still happen on the latest Intel 26.20.100.8141 graphics driver?

(In reply to Jessie [:jbonisteel] pls NI from comment #2)

Can you go to about:config, look for gfx.webrender.compositor and if that is true, flip it to false. Restart, and let me know if you still see this issue?

Configuration was "true". Flipped it to "false", and so far so good. If anything pops in the next few days I'll report.

Flags: needinfo?(dekeltal)

(In reply to GMA from comment #3)

https://downloadcenter.intel.com/download/29530/Intel-Graphics-Windows-10-DCH-Drivers

Does it still happen on the latest Intel 26.20.100.8141 graphics driver?

Went to the above site. Intel specifically recommends NOT to replace my existing OEM graphics driver into the generic Intel one:
"OEM drivers are handpicked, customized, and validated to resolve platform-specific issues, enable features and enhancements, and improve system stability. Intel’s generic graphics drivers are intended for testing, and we recommend using drivers from Hewlett-Packard (HP). "

Following the above advice, I did not update to the generic Intel driver.

Potential DC bug. Bug 1634171 is maybe similar, however that reporter is saying the issue does not go away when they flip compositor to false.

Flags: needinfo?(jmuizelaar)
Flags: needinfo?(gwatson)

This appears to be a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1603515.

There seems to be a driver bug which causes those artifacts.

In that bug, we disabled DirectComposition support on any driver older than 25.20.100.6472.

The driver in this bug report is:

Driver Version: 26.20.100.7263
Driver Date: 9-25-2019

This driver also seems to show the bug, so we'll probably need to extend the driver blocklist to that version, unfortunately.

In that previous bug, we had a similar situation where if we force updated the driver to what Intel provided, it fixed the bug. However, the OEM hadn't provided an updated driver from Intel.

The simplest option is probably to blocklist up to that driver version for DC, although that may be a significant number of users. Alternatively, we can try to reproduce locally and spend some time trying to find a workaround (I did spend some time looking at it last time and wasn't able to find a workaround).

Jess, Jessie, thoughts on what we should do here?

Flags: needinfo?(gwatson) → needinfo?(jbonisteel)

Jeff, what would the implications be if we just block DC but allow WR? (aside from supporting the two paths)

We'll need to support both paths anyways because of win7, the only other big implication is reduced performance.

I looked in the other bug and didn't see anything about this being resolved by updating the driver. In fact, I think I've seen this locally once or twice and I'm on a newer driver than this one.

I'm open to blocking this driver (especially in release) but it would be good to get some more information on what's going on.

Flags: needinfo?(jmuizelaar)
Blocks: wr-77
No longer blocks: gfx-triage
Flags: needinfo?(jbonisteel)

Chatted more with Jeff. We will avoid blocking for now and see if we get more reports that will help us learn more about what is going on and if there could be a potential workaround.

Upgraded to nightly 78, unfortunately still occasionally have this artifacts - in the toolbar, and also on the webpage (see new attachments)

Priority: -- → P3

https://downloadcenter.intel.com/download/29554/Intel-Graphics-Windows-10-DCH-Drivers

Intel 27.20.100.8187 WDDM 2.7 driver if anyone wants to test it with this issue.

Dekel, I noticed this page:
https://downloadcenter.intel.com/download/29554/Intel-Graphics-Windows-10-DCH-Drivers

Says:

Any graphics issues found using Intel generic graphics drivers should be reported directly to Intel.

You you be willing to report your issue to Intel as well? We might be able to get more insight from them. We will also try reaching out to Intel

Flags: needinfo?(dekeltal)

(In reply to Jessie [:jbonisteel] pls NI from comment #15)

Dekel, I noticed this page:
https://downloadcenter.intel.com/download/29554/Intel-Graphics-Windows-10-DCH-Drivers

Says:

Any graphics issues found using Intel generic graphics drivers should be reported directly to Intel.

You you be willing to report your issue to Intel as well? We might be able to get more insight from them. We will also try reaching out to Intel

Jessie, the note above is for users of the generic Intel drivers. I'm not using Intel's generic graphic driver, but rather the OEM HP driver that was delivered with my laptop. As commented above, since Intel actually recommends NOT to override any OEM driver with their generic one, I prefer not to do so.

Flags: needinfo?(dekeltal)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is P3 (Backlog,) indicating it has been triaged, the bug's Severity is being updated to S3 (normal.)

Severity: normal → S3
See Also: → 1638672
Blocks: wr-78
No longer blocks: wr-77
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Assignee: nobody → dmalyshau
Depends on: 1638672
Target Milestone: --- → mozilla79
QA Whiteboard: [qa-79b-p2]
You need to log in before you can comment on or make changes to this bug.