Closed Bug 1634779 Opened 2 months ago Closed 2 months ago

Re-enable browser.tabs.remote.allowLinkedWebInFileUriProcess in Firefox 76

Categories

(Core :: DOM: Content Processes, task, P1)

task

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- wontfix
firefox77 + verified
firefox78 --- verified

People

(Reporter: cpeterson, Assigned: pbone)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

[Tracking Requested - why for this release]:

pbone recommends in bug 1603006 comment 7 that we re-enable browser.tabs.remote.allowLinkedWebInFileUriProcess in Firefox 76 to fix the regressions (like bug 1632441, bug 1634252, bug 1629441, and bug 1630757).

Will we need to re-enable in Firefox 77+ if we can't fix the regressions during 77 Beta? The browser.tabs.remote.allowLinkedWebInFileUriProcess code was removed in 77 Nightly by bug 1603007.

Flags: needinfo?(jcristau)

Working on it now.

Status: NEW → ASSIGNED
Duplicate of this bug: 1634997

76 ships tomorrow, the builds happened last week...

Flags: needinfo?(jcristau) → needinfo?(ryanvm)

Comment on attachment 9145358 [details]
Bug 1634779 - pt 2. Partially revert Bug 1603006 r=kmag

Beta/Release Uplift Approval Request

  • User impact if declined: Bug 1632441 and Bug 1634252 will continue to affect users.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: The code is covered by automatic tests but not all behaviours are covered. I'm developing new tests now.

STR for Bug 1632441:

  • Go to that bug,
  • Download and unzip the nodejs webserver attachment.
  • Run the server node server.js
  • Open the test.html file locally with a file:// URL.
  • A new tab will appear, it says "Should close in a few seconds",
  • The new tab closes.

STR Bug 1634252 - exactly as written in this bug.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change restores a behaviour that existed prior to Firefox 75. The possible risk is if it interacts badly with changes made in 75 or later. I think the chance of a bad interaction is low but not impossible.
  • String changes made/needed: none.
Attachment #9145358 - Flags: approval-mozilla-beta?
Flags: qe-verify+

(In reply to Julien Cristau [:jcristau] from comment #4)

76 ships tomorrow, the builds happened last week...

Hrm, damn. I guess I'll land it in nightly (if it can make the 77 train) or request uplift to 77. and fix the bugs properly in 78. If it goes okay in 77 then I guess I request uplift to 76 and IDK who makes that call.

Comment on attachment 9145358 [details]
Bug 1634779 - pt 2. Partially revert Bug 1603006 r=kmag

Removing the uplift request until we check this in central. Since the beta->release train has already left there's no point landing in beta first.

Attachment #9145358 - Flags: approval-mozilla-beta?

Can we re-enable this pref via Normandy for 76?

Flags: needinfo?(ryanvm)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)

Can we re-enable this pref via Normandy for 76?

No, it needs a code change also I'm afraid.

I don't think I can land this without breaking other features. I'll see if it's possible but if it's not Bug 1550571 may be a better solution.

Even so, today Nika, Matt and I talked about Bug 1550571 riding the trains vs this one getting an uplift. So I'll continut to look at this for Beta's sake.

(In reply to Paul Bone [:pbone] from comment #11)

Even so, today Nika, Matt and I talked about Bug 1550571 riding the trains vs this one getting an uplift. So I'll continut to look at this for Beta's sake.

Paul, should we WONTFIX this bug? IIUC, we plan to uplift your individual regression fixes to Fx77 Beta instead of a full backout in a Fx76.0.x dot release.

Flags: needinfo?(pbone)
Attachment #9145358 - Attachment description: Bug 1634779 - Re-enable allowLinkedWebInFileUriProcess r=kmag → Bug 1634779 - Partially revert Bug 1603006 r=kmag

(In reply to Chris Peterson [:cpeterson] from comment #12)

(In reply to Paul Bone [:pbone] from comment #11)

Even so, today Nika, Matt and I talked about Bug 1550571 riding the trains vs this one getting an uplift. So I'll continut to look at this for Beta's sake.

Paul, should we WONTFIX this bug? IIUC, we plan to uplift your individual regression fixes to Fx77 Beta instead of a full backout in a Fx76.0.x dot release.

I hope I clarifled in our meeting today. I am aiming to fix and uplift this to 77. I've maked 76 as "wontfix" and removed tracking. Bug 1550571 is the "correct" fix and we plan for it to ride the trains.

Flags: needinfo?(pbone)
See Also: → 1550571
Attachment #9145358 - Attachment description: Bug 1634779 - Partially revert Bug 1603006 r=kmag → Bug 1634779 - pt 2. Partially revert Bug 1603006 r=kmag
Attachment #9148241 - Attachment description: Bug 1634779 - pt 1. Navigate in this test in the context of the content r=kmag → Bug 1634779 - pt 1. Improvments to browser_httpToFileHistory.js test r=kmag
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/230d4500714c
pt 1. Improvments to browser_httpToFileHistory.js test r=kmag
https://hg.mozilla.org/integration/autoland/rev/79effd7127ec
pt 2. Partially revert Bug 1603006 r=kmag

Reminder to myself to request uplift in a few days time.

Flags: needinfo?(pbone)
Keywords: leave-open
Blocks: 1639095

Is the leave-open because you expect more patches for this bug? (It's not necessary or appropriate if it's just for the uplift, as we track that separately with status flags)

Jcristau, Yes it was a note to myself that I'm not done with this. Sorry if it was confusing.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Flags: needinfo?(pbone)
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Comment on attachment 9148241 [details]
Bug 1634779 - pt 1. Improvments to browser_httpToFileHistory.js test r=kmag

Beta/Release Uplift Approval Request

  • User impact if declined: This change works around several issues when navigating from file:// to http:// URLs.
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: There's limited coverage from automated tests.

The STR from Bug 1632441 and Bug 1634252 can be used to verify this is fixed.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change restores a previous behavour of Firefox, this is a low risk because it's a behaviour we had until Firefox 77.
  • String changes made/needed: None
Attachment #9148241 - Flags: approval-mozilla-beta?
Attachment #9145358 - Flags: approval-mozilla-beta?

Comment on attachment 9148241 [details]
Bug 1634779 - pt 1. Improvments to browser_httpToFileHistory.js test r=kmag

P1 critical bug, evaluated to low risk by the dev, covered by tests and verified in Nightly, uplift approved for 77 beta 9, thanks!

Attachment #9148241 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9145358 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Using the steps from the bugs in comment 20 i was able to :
Reproduce the issue on Firefox 77.0a1 (20200419091145) on Windows 10 and Ubuntu 18.04.4.
Verified fixed on Firefox 78.0a1 (20200521093657) and Firefox 77.0b9 (20200521224544).

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Blocks: 1636364
You need to log in before you can comment on or make changes to this bug.