Closed Bug 1634993 Opened 3 months ago Closed 3 months ago

Tooltip for Print button shows "Print this message"

Categories

(SeaMonkey :: Composer, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Regression)

Details

(Whiteboard: SM2.53.3)

Attachments

(1 file)

When Bug 718517 landed it meant that web composer had its tooltip overridden by mailOverlay.xul so became "Print this message" rather than "Print this page"

This patch:

  • Moves print button overlay from editorOverlay to editingOverlay so it is only used for web composer and debugQA text editor
  • Moves print button overlay out of mailOverlay into mailWindowOverlay and messengercompose so it is only used in mail windows.

[Approval Request Comment]
Regression caused by (bug #): 718517
User impact if declined: Incorrect tooltip for print button
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: movement of strings between dtd files

Attachment #9145335 - Flags: review?(frgrahl)
Attachment #9145335 - Flags: approval-comm-release?
Attachment #9145335 - Flags: approval-comm-esr60?
Comment on attachment 9145335 [details] [diff] [review]
Fix print button tooltip

LGTM
Attachment #9145335 - Flags: review?(frgrahl)
Attachment #9145335 - Flags: review+
Attachment #9145335 - Flags: approval-comm-release?
Attachment #9145335 - Flags: approval-comm-release+
Attachment #9145335 - Flags: approval-comm-esr60?
Attachment #9145335 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/f2646b70e308
Tooltip for Print button shows "Print this message". r=frg

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.