Closed Bug 1635454 Opened 5 months ago Closed 4 months ago

Update instant messaging fields in the address book

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, enhancement)

enhancement

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.75
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.3)

Attachments

(2 files, 1 obsolete file)

Port the relevant parts of the following bugs to SeaMonkey:

  • Bug 759328 - Add instant messaging fields to the address book cards
  • Bug 792800 - Add a field for IRC nicknames in the Address Book
Attached patch Enhance instant messaging fields (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: only the one IM field
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: 30+ new and 6 removals

Attachment #9145861 - Flags: review?(frgrahl)
Attachment #9145861 - Flags: approval-comm-release?
Attachment #9145861 - Flags: approval-comm-esr60?
Blocks: 1636098

Fix clash in accesskeys

Attachment #9145861 - Attachment is obsolete: true
Attachment #9145861 - Flags: review?(frgrahl)
Attachment #9145861 - Flags: approval-comm-release?
Attachment #9145861 - Flags: approval-comm-esr60?
Attachment #9149853 - Flags: review?(frgrahl)
Attachment #9149853 - Flags: approval-comm-release?
Attachment #9149853 - Flags: approval-comm-esr60?
Comment on attachment 9149853 [details] [diff] [review]
Enhance instant messaging fields v1.1

LGTM

For comm-central
mailnews/addrbook/content/abResultsPaneOverlay.xul is now suite/mailnews/addrbook/content/abResultsPaneOverlay.xhtml.
Part in mailnews/addrbook/src/nsAbCardProperty.cpp seems to be applyable 1:1
Attachment #9149853 - Flags: review?(frgrahl)
Attachment #9149853 - Flags: review+
Attachment #9149853 - Flags: approval-comm-release?
Attachment #9149853 - Flags: approval-comm-release+
Attachment #9149853 - Flags: approval-comm-esr60?
Attachment #9149853 - Flags: approval-comm-esr60+

As per irc discussion

Attachment #9151039 - Flags: review+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/17a3b9a2aeed
Update instant messaging fields in the address book. r=frg DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.75
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.