Closed Bug 1635773 Opened 5 months ago Closed 4 months ago

Update how screen is refreshed when switching address books

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

defect

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.75
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.3)

Attachments

(1 file)

At the moment:
The search field is cleared when clicking on the current address book
The previously selected contact is left displayed after switching to a different address book

This patch ports the relevant parts of the following bugs to SeaMonkey:

  • Bug 900541 - Contacts side bar: Don't pre-select first address when changing address book
  • Bug 1140846 - Save some unnecessary calls to abResultsPane.js::SetAbView in addressbook window and Contacts sidebar

It also moves onAbClearSearch into abCommon.js to match the location in TB.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: address book views do not refresh correctly
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9146164 - Flags: review?(frgrahl)
Attachment #9146164 - Flags: approval-comm-release?
Attachment #9146164 - Flags: approval-comm-esr60?
Blocks: 1636098
Comment on attachment 9146164 [details] [diff] [review]
Addressbook switch patch

LGTM
Attachment #9146164 - Flags: review?(frgrahl)
Attachment #9146164 - Flags: review+
Attachment #9146164 - Flags: approval-comm-release?
Attachment #9146164 - Flags: approval-comm-release+
Attachment #9146164 - Flags: approval-comm-esr60?
Attachment #9146164 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/1bf6acb1b68d
Update how screen is refreshed when switching address books. r=frg

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.75
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.